CVE-2010-1618
CVE-2010-1618
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Cross-site scripting (XSS) vulnerability in the phpCAS client library before 1.1.0, as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via a crafted URL, which is not properly handled in an error message.
EPSS 1.8% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
apereo/phpcas Packagist
- Affected ranges
- ECOSYSTEM: < 1.1.0
Update to 1.1.0
moodle/moodle Packagist
- Affected ranges
- ECOSYSTEM: ≥ 1.8.0, < 1.8.12
Update to 1.8.12
moodle/moodle Packagist
- Affected ranges
- ECOSYSTEM: ≥ 1.9.0, < 1.9.8
Update to 1.9.8