p PatchFirst

PatchFirst · Latest vulnerabilities

apereo/phpcas vulnerabilities

Vulnerabilities published for apereo/phpcas in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2022-39369

    High · CVSS 8EPSS 2.43%Fix available

    Service Hostname Discovery Exploitation in phpCAS

    phpCAS is an authentication library that allows PHP applications to easily authenticate users via a Central Authentication Service (CAS) server. The phpCAS library uses HTTP headers to determine the service URL used to validate tickets. This allows an attacker to control the host header and use a valid ticket granted for any authorized service in the same SSO realm (CAS server) to authenticate to the service protected by phpCAS. Depending on the settings of the CAS server service registry in worst case this may be any other service URL (if the allowed URLs are configured to "^(https)://.*") or may be strictly limited to known and authorized s

    • Update to 1.6.0
    Published Updated
  2. CVE-2010-1618

    Not ratedEPSS 1.81%Fix available

    CVE-2010-1618

    Cross-site scripting (XSS) vulnerability in the phpCAS client library before 1.1.0, as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via a crafted URL, which is not properly handled in an error message.

    • Update to 1.1.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →