p PatchFirst

CVE-2010-2235

CVE-2010-2235

This page contains facts from public vulnerability sources. Check the original advisory before updating.

template_api.py in Cobbler before 2.0.7, as used in Red Hat Network Satellite Server and other products, does not disable the ability of the Cheetah template engine to execute Python statements contained in templates, which allows remote authenticated administrators to execute arbitrary code via a crafted kickstart template file, a different vulnerability than CVE-2008-6954.

EPSS 3.3% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • cobbler PyPI

    Versions
    • 0.6.3-2
    Affected ranges
    • ECOSYSTEM: < 2.0.7

    Update to 2.0.7

Original sources

Check your server →