p PatchFirst

PatchFirst · Latest vulnerabilities

cobbler vulnerabilities

Vulnerabilities published for cobbler in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 18

  1. CVE-2024-47533

    Critical · CVSS 9.8EPSS 4%Public exploitFix available

    Cobbler allows anyone to connect to cobbler XML-RPC server with a known password and make changes

    Cobbler, a Linux installation server that allows for rapid setup of network installation environments, has an improper authentication vulnerability starting in version 3.0.0 and prior to versions 3.2.3 and 3.3.7. `utils.get_shared_secret()` always returns `-1`, which allows anyone to connect to cobbler XML-RPC as user `''` password `-1` and make any changes. This gives anyone with network access to a cobbler server full control of the server. Versions 3.2.3 and 3.3.7 fix the issue.

    • Update to 3.2.3
    • Update to 3.3.7
    Published Updated
  2. CVE-2021-45083

    High · CVSS 8.6EPSS 0.31%Fix available

    CVE-2021-45083

    An issue was discovered in Cobbler before 3.3.1. Files in /etc/cobbler are world readable. Two of those files contain some sensitive information that can be exposed to a local user who has non-privileged access to the server. The users.digest file contains the sha2-512 digest of users in a Cobbler local installation. In the case of an easy-to-guess password, it's trivial to obtain the plaintext string. The settings.yaml file contains secrets such as the hashed default password.

    • Update to 3.3.1
    Published Updated
  3. CVE-2016-9605

    Medium · CVSS 6.1EPSS 0.81%No fix published

    CVE-2016-9605

    A flaw was found in cobbler software component version 2.6.11-1. It suffers from an invalid parameter validation vulnerability, leading the arbitrary file reading. The flaw is triggered by navigating to a vulnerable URL via cobbler-web on a default installation.

    Published Updated
  4. CVE-2018-1000226

    Critical · CVSS 9.8EPSS 12.58%Public exploitFix available

    CVE-2018-1000226

    Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection suggests at least 2.0.0+ or possibly even older versions may be vulnerable contains a Incorrect Access Control vulnerability in XMLRPC API (/cobbler_api) that can result in Privilege escalation, data manipulation or exfiltration, LDAP credential harvesting. This attack appear to be exploitable via "network connectivity". Taking advantage of improper validation of security tokens in API endpoints. Please note this is a different issue than CVE-2018-10931.

    • Update to 3.0.0
    Published Updated
  5. CVE-2018-1000225

    Medium · CVSS 6.1EPSS 1.27%No fix published

    CVE-2018-1000225

    Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection suggests at least 2.0.0+ or possibly even older versions may be vulnerable contains a Cross Site Scripting (XSS) vulnerability in cobbler-web that can result in Privilege escalation to admin.. This attack appear to be exploitable via "network connectivity". Sending unauthenticated JavaScript payload to the Cobbler XMLRPC API (/cobbler_api).

    Published Updated
  6. CVE-2018-10931

    Critical · CVSS 9.8EPSS 68.08%Public exploitFix available

    CVE-2018-10931

    It was found that cobbler 2.6.x exposed all functions from its CobblerXMLRPCInterface class over XMLRPC. A remote, unauthenticated attacker could use this flaw to gain high privileges within cobbler, upload files to arbitrary location in the context of the daemon.

    • Update to 3.0.0
    Published Updated
  7. CVE-2011-4953

    Not ratedEPSS 2.19%Fix available

    CVE-2011-4953

    The set_mgmt_parameters function in item.py in cobbler before 2.2.2 allows context-dependent attackers to execute arbitrary code via vectors related to the use of the yaml.load function instead of the yaml.safe_load function, as demonstrated using Puppet.

    • Update to 2.6.0
    Published Updated
  8. CVE-2010-2235

    Not ratedEPSS 3.29%Fix available

    CVE-2010-2235

    template_api.py in Cobbler before 2.0.7, as used in Red Hat Network Satellite Server and other products, does not disable the ability of the Cheetah template engine to execute Python statements contained in templates, which allows remote authenticated administrators to execute arbitrary code via a crafted kickstart template file, a different vulnerability than CVE-2008-6954.

    • Update to 2.0.7
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →