p PatchFirst

CVE-2010-4180

CVE-2010-4180

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

OpenSSL before 0.9.8q, and 1.0.x before 1.0.0c, when SSL_OP_NETSCAPE_REUSE_CIPHER_CHANGE_BUG is enabled, does not properly prevent modification of the ciphersuite in the session cache, which allows remote attackers to force the downgrade to an unintended cipher via vectors involving sniffing network traffic to discover a session identifier.

EPSS 9.5% · Fix available

Published
Updated

Stack: system · network

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • openssl Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.9.8o-4

    Update to 0.9.8o-4

  • openssl Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.9.8o-4

    Update to 0.9.8o-4

  • openssl Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.9.8o-4

    Update to 0.9.8o-4

Original sources

Check your server →