p PatchFirst

CVE-2011-3587

CVE-2011-3587

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Unspecified vulnerability in Zope 2.12.x and 2.13.x, as used in Plone 4.0.x through 4.0.9, 4.1, and 4.2 through 4.2a2, allows remote attackers to execute arbitrary commands via vectors related to the p_ class in OFS/misc_.py and the use of Python modules.

EPSS 78.1% · Public exploit · Fix available

Published
Updated

Stack: python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • zope2 PyPI

    Versions
    • 2.12.0
    • 2.12.1
    • 2.12.10
    • 2.12.11
    • 2.12.12
    • 2.12.13
    • 2.12.14
    • 2.12.15
    • 2.12.16
    • 2.12.17
    • 2.12.18
    • 2.12.19
    • 2.12.2
    • 2.12.3
    • 2.12.4
    • 2.12.5
    • 2.12.6
    • 2.12.7
    • 2.12.8
    • 2.12.9
    Affected ranges
    • ECOSYSTEM: ≥ 2.12.0, < 2.12.20

    Update to 2.12.20

  • zope2 PyPI

    Versions
    • 2.13.0
    • 2.13.1
    • 2.13.2
    • 2.13.3
    • 2.13.4
    • 2.13.5
    • 2.13.6
    • 2.13.7
    • 2.13.8
    • 2.13.9
    Affected ranges
    • ECOSYSTEM: ≥ 2.13.0, < 2.13.10

    Update to 2.13.10

  • zope2 PyPI

    Versions
    • 2.12.0
    • 2.12.1
    • 2.12.10
    • 2.12.11
    • 2.12.12
    • 2.12.13
    • 2.12.14
    • 2.12.15
    • 2.12.16
    • 2.12.17
    • 2.12.18
    • 2.12.19
    • 2.12.2
    • 2.12.3
    • 2.12.4
    • 2.12.5
    • 2.12.6
    • 2.12.7
    • 2.12.8
    • 2.12.9
    • 2.13.0
    • 2.13.1
    • 2.13.2
    • 2.13.3
    • 2.13.4
    • 2.13.5
    • 2.13.6
    • 2.13.7
    • 2.13.8
    • 2.13.9
    Affected ranges
    • ECOSYSTEM: ≥ 2.12.0, < 2.12.20 ∪ ≥ 2.13.0, < 2.13.10

    Update to 2.12.20; Update to 2.13.10

Original sources

Check your server →