p PatchFirst

CVE-2011-4577

CVE-2011-4577

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenSSL before 0.9.8s and 1.x before 1.0.0f, when RFC 3779 support is enabled, allows remote attackers to cause a denial of service (assertion failure) via an X.509 certificate containing certificate-extension data associated with (1) IP address blocks or (2) Autonomous System (AS) identifiers.

EPSS 8.2% · Fix available

Published
Updated

Stack: system · network

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • openssl Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.0.0f-1

    Update to 1.0.0f-1

  • openssl Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.0.0f-1

    Update to 1.0.0f-1

  • openssl Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.0.0f-1

    Update to 1.0.0f-1

Original sources

Check your server →