CVE-2011-4924
CVE-2011-4924
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3, 3.1.1 through 3.4.1. allows remote attackers to inject arbitrary web script or HTML via vectors related to the way error messages perform sanitization. NOTE: this issue exists because of an incomplete fix for CVE-2010-1104
CVSS 6.1 · Medium · EPSS 1.4% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
zope2, zope3
- Versions
- 2.8.x before 2.8.12: Affected
- 2.9.x before 2.9.12: Affected
- 2.10.x before 2.10.11: Affected
- 2.11.x before 2.11.6: Affected
- and 2.12.x before 2.12.3: Affected
- 3.1.1through 3.4.1: Affected
No fix published
zope PyPI
- Affected ranges
- ECOSYSTEM: ≥ 3.1.1, < 3.7.3
Update to 3.7.3
zope2 PyPI
- Versions
- 2.12.0
- 2.12.0.a1
- 2.12.0a2
- 2.12.0a3
- 2.12.0a4
- 2.12.0b1
- 2.12.0b2
- 2.12.0b3
- 2.12.0b4
- 2.12.0c1
- 2.12.1
- 2.12.10
- 2.12.11
- 2.12.12
- 2.12.13
- 2.12.14
- 2.12.15
- 2.12.16
- 2.12.17
- 2.12.18
- 2.12.19
- 2.12.2
- 2.12.20
- 2.12.21
- 2.12.3
- 2.12.4
- 2.12.5
- 2.12.6
- 2.12.7
- 2.12.8
- 2.12.9
- Affected ranges
- ECOSYSTEM: < 2.12.22
Update to 2.12.22
zope2 PyPI
- Versions
- 2.13.0
- 2.13.0a1
- 2.13.0a2
- 2.13.0a3
- 2.13.0a4
- 2.13.0b1
- 2.13.0c1
- 2.13.1
- 2.13.10
- 2.13.11
- 2.13.2
- 2.13.3
- 2.13.4
- 2.13.5
- 2.13.6
- 2.13.7
- 2.13.8
- 2.13.9
- Affected ranges
- ECOSYSTEM: ≥ 2.13.0a1, < 2.13.12
Update to 2.13.12
zope2 PyPI
- Versions
- 2.12.0
- 2.12.0.a1
- 2.12.0a2
- 2.12.0a3
- 2.12.0a4
- 2.12.0b1
- 2.12.0b2
- 2.12.0b3
- 2.12.0b4
- 2.12.0c1
- 2.12.1
- 2.12.10
- 2.12.11
- 2.12.12
- 2.12.13
- 2.12.14
- 2.12.15
- 2.12.16
- 2.12.17
- 2.12.18
- 2.12.19
- 2.12.2
- 2.12.20
- 2.12.21
- 2.12.3
- 2.12.4
- 2.12.5
- 2.12.6
- 2.12.7
- 2.12.8
- 2.12.9
- 2.13.0
- 2.13.0a1
- 2.13.0a2
- 2.13.0a3
- 2.13.0a4
- 2.13.0b1
- 2.13.0c1
- 2.13.1
- 2.13.10
- 2.13.11
- 2.13.2
- 2.13.3
- 2.13.4
- 2.13.5
- 2.13.6
- 2.13.7
- 2.13.8
- 2.13.9
- Affected ranges
- ECOSYSTEM: < 2.12.22 ∪ ≥ 2.13.0a1, < 2.13.12
Update to 2.12.22; Update to 2.13.12
Original sources
- https://security-tracker.debian.org/tracker/CVE-2011-4924
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2011-4924
- https://access.redhat.com/security/cve/cve-2011-4924
- http://www.openwall.com/lists/oss-security/2012/01/19/19
- http://www.openwall.com/lists/oss-security/2012/01/19/16
- http://www.openwall.com/lists/oss-security/2012/01/19/17
- http://www.openwall.com/lists/oss-security/2012/01/19/18
- https://nvd.nist.gov/vuln/detail/CVE-2011-4924