p PatchFirst

CVE-2011-4953

CVE-2011-4953

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The set_mgmt_parameters function in item.py in cobbler before 2.2.2 allows context-dependent attackers to execute arbitrary code via vectors related to the use of the yaml.load function instead of the yaml.safe_load function, as demonstrated using Puppet.

EPSS 2.2% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • cobbler PyPI

    Versions
    • 0.6.3-2
    Affected ranges
    • ECOSYSTEM: < 2.6.0

    Update to 2.6.0

Original sources

Check your server →