p PatchFirst

CVE-2011-4969

CVE-2011-4969

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in jQuery before 1.6.3, when using location.hash to select elements, allows remote attackers to inject arbitrary web script or HTML via a crafted tag.

EPSS 19.2% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • jquery npm

    Affected ranges
    • SEMVER: < 1.6.3

    Update to 1.6.3

  • jquery NuGet

    Versions
    • 1.4.1
    • 1.4.2
    • 1.4.3
    • 1.4.4
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.6.0
    • 1.6.1
    • 1.6.2
    Affected ranges
    • ECOSYSTEM: < 1.6.3

    Update to 1.6.3

  • jquery-rails RubyGems

    Versions
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.2
    • 0.2.1
    • 0.2.2
    • 0.2.3
    • 0.2.4
    • 0.2.5
    • 0.2.6
    • 0.2.7
    • 1.0
    • 1.0.1
    • 1.0.10
    • 1.0.11
    • 1.0.12
    • 1.0.13
    • 1.0.14
    • 1.0.15
    • 1.0.2
    • 1.0.3
    • 1.0.4
    • 1.0.5
    • 1.0.6
    • 1.0.7
    • 1.0.8
    • 1.0.9
    • 1.0.rc
    Affected ranges
    • ECOSYSTEM: < 1.0.16

    Update to 1.0.16

  • org.webjars.npm:jquery Maven

    Affected ranges
    • ECOSYSTEM: < 1.6.3

    Update to 1.6.3

Original sources

Check your server →