p PatchFirst

PatchFirst · Latest vulnerabilities

jquery-rails vulnerabilities

Vulnerabilities published for jquery-rails in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 8

  1. CVE-2020-7656

    Medium · CVSS 6.1EPSS 6.43%Public exploitFix available

    CVE-2020-7656

    jquery prior to 1.9.0 allows Cross-site Scripting attacks via the load method. The load method fails to recognize and remove "<script>" HTML tags that contain a whitespace character, i.e: "</script >", which results in the enclosed script logic to be executed.

    • Update to 2.2.0
    Published Updated
  2. CVE-2020-11023

    Medium · CVSS 6.9EPSS 84.89%In KEVPublic exploitFix available

    Potential XSS vulnerability in jQuery

    In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

    • Update to 4.4.0
    Published Updated
  3. CVE-2020-11022

    Medium · CVSS 6.9EPSS 99.22%Public exploitFix available

    jQuery has a potential XSS vulnerability

    In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

    • Update to 4.4.0
    Published Updated
  4. CVE-2019-11358

    Medium · CVSS 6.1EPSS 86.82%Public exploitFix available

    CVE-2019-11358

    jQuery before 3.4.0, as used in Drupal, Backdrop CMS, and other products, mishandles jQuery.extend(true, {}, ...) because of Object.prototype pollution. If an unsanitized source object contained an enumerable __proto__ property, it could extend the native Object.prototype.

    • Update to 4.3.4
    Published Updated
  5. CVE-2016-10707

    High · CVSS 7.5EPSS 3.23%Fix available

    CVE-2016-10707

    jQuery 3.0.0-rc.1 is vulnerable to Denial of Service (DoS) due to removing a logic that lowercased attribute names. Any attribute getter using a mixed-cased name for boolean attributes goes into an infinite recursion, exceeding the stack call limit.

    • Update to 3.0.0
    Published Updated
  6. CVE-2012-6708

    Medium · CVSS 6.1EPSS 8.63%Public exploitFix available

    CVE-2012-6708

    jQuery before 1.9.0 is vulnerable to Cross-site Scripting (XSS) attacks. The jQuery(strInput) function does not differentiate selectors from HTML in a reliable fashion. In vulnerable versions, jQuery determined whether the input was HTML by looking for the '<' character anywhere in the string, giving attackers more flexibility when attempting to construct a malicious payload. In fixed versions, jQuery only deems the input to be HTML if it explicitly starts with the '<' character, limiting exploitability only to attackers who can control the beginning of a string, which is far less common.

    • Update to 2.2.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →