CVE-2012-0040
CVE-2012-0040
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Cross-site scripting (XSS) vulnerability in modules/core/www/no_cookie.php in SimpleSAMLphp 1.8.1 and possibly other versions before 1.8.2 allows remote attackers to inject arbitrary web script or HTML via the retryURL parameter.
EPSS 1.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
simplesamlphp Debian:12
- Affected ranges
- ECOSYSTEM: < 1.8.2-1
Update to 1.8.2-1
simplesamlphp Debian:14
- Versions
- 1.6.0-1
- 1.6.1-1
- 1.6.2-1
- 1.6.3-1
- 1.6.3-2
- 1.6.3-3
- 1.7.0-1
- 1.7.0-2
- 1.8.0-1
- 1.8.1-1
- Affected ranges
- ECOSYSTEM: < 1.8.2-1
Update to 1.8.2-1
Original sources
- https://exchange.xforce.ibmcloud.com/vulnerabilities/72313
- http://secunia.com/advisories/47534
- http://code.google.com/p/simplesamlphp/issues/detail?id=468
- http://osvdb.org/78254
- http://www.openwall.com/lists/oss-security/2012/01/20/20
- http://www.securityfocus.com/bid/51372
- http://secunia.com/advisories/47491
- http://www.debian.org/security/2012/dsa-2387
- https://nvd.nist.gov/vuln/detail/CVE-2012-0040