p PatchFirst

CVE-2012-2870

CVE-2012-2870

This page contains facts from public vulnerability sources. Check the original advisory before updating.

libxslt 1.1.26 and earlier, as used in Google Chrome before 21.0.1180.89, does not properly manage memory, which might allow remote attackers to cause a denial of service (application crash) via a crafted XSLT expression that is not properly identified during XPath navigation, related to (1) the xsltCompileLocationPathPattern function in libxslt/pattern.c and (2) the xsltGenerateIdFunction function in libxslt/functions.c.

EPSS 2.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libxslt Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.1.26-14

    Update to 1.1.26-14

  • libxslt Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.1.26-14

    Update to 1.1.26-14

  • libxslt Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.1.26-14

    Update to 1.1.26-14

Original sources

Check your server →