p PatchFirst

PatchFirst · Latest vulnerabilities

libxslt vulnerabilities

Vulnerabilities published for libxslt in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 33

  1. CVE-2025-11731

    Low · CVSS 3.1EPSS 0.28%No fix published

    Libxslt: type confusion in exsltfuncresultcompfunction of libxslt

    A flaw was found in the exsltFuncResultComp() function of libxslt, which handles EXSLT <func:result> elements during stylesheet parsing. Due to improper type handling, the function may treat an XML document node as a regular XML element node, resulting in a type confusion. This can cause unexpected memory reads and potential crashes. While difficult to exploit, the flaw could lead to application instability or denial of service.

    Published Updated
  2. CVE-2025-7424

    High · CVSS 7.5EPSS 1.3%Fix available

    Libxslt: type confusion in xmlnode.psvi between stylesheet and source nodes

    A flaw was found in the libxslt library. The same memory field, psvi, is used for both stylesheet and input data, which can lead to type confusion during XML transformations. This vulnerability allows an attacker to crash the application or corrupt memory. In some cases, it may lead to denial of service or unexpected behavior.

    • Update to 1.1.35-1.2+deb13u1
    Published Updated
  3. CVE-2025-24855

    High · CVSS 7.8EPSS 0.36%Fix available

    CVE-2025-24855

    numbers.c in libxslt before 1.1.43 has a use-after-free because, in nested XPath evaluations, an XPath context node can be modified but never restored. This is related to xsltNumberFormatGetValue, xsltEvalXPathPredicate, xsltEvalXPathStringNs, and xsltComputeSortResultInternal.

    • Update to 1.1.35-1.2
    Published Updated
  4. CVE-2019-18197

    High · CVSS 7.5EPSS 4.45%Fix available

    CVE-2019-18197

    In xsltCopyText in transform.c in libxslt 1.1.33, a pointer variable isn't reset under certain circumstances. If the relevant memory area happened to be freed and reused in a certain way, a bounds check could fail and memory outside a buffer could be written to, or uninitialized data could be disclosed.

    • Update to 1.1.32-2.2
    Published Updated
  5. CVE-2017-5029

    High · CVSS 8.8EPSS 2.16%Fix available

    CVE-2017-5029

    The xsltAddTextString function in transform.c in libxslt 1.1.29, as used in Blink in Google Chrome prior to 57.0.2987.98 for Mac, Windows, and Linux and 57.0.2987.108 for Android, lacked a check for integer overflow during a size calculation, which allowed a remote attacker to perform an out of bounds memory write via a crafted HTML page.

    • Update to 1.1.29-2.1
    Published Updated
  6. CVE-2016-4610

    Critical · CVSS 9.8EPSS 4.96%Fix available

    CVE-2016-4610

    libxslt in Apple iOS before 9.3.3, OS X before 10.11.6, iTunes before 12.4.2 on Windows, iCloud before 5.2.1 on Windows, tvOS before 9.2.2, and watchOS before 2.2.2 allows remote attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact via unknown vectors, a different vulnerability than CVE-2016-4607, CVE-2016-4608, CVE-2016-4609, and CVE-2016-4612.

    • Update to 1.1.29-1
    Published Updated
  7. CVE-2016-4609

    Critical · CVSS 9.8EPSS 5.01%Fix available

    CVE-2016-4609

    libxslt in Apple iOS before 9.3.3, OS X before 10.11.6, iTunes before 12.4.2 on Windows, iCloud before 5.2.1 on Windows, tvOS before 9.2.2, and watchOS before 2.2.2 allows remote attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact via unknown vectors, a different vulnerability than CVE-2016-4607, CVE-2016-4608, CVE-2016-4610, and CVE-2016-4612.

    • Update to 1.1.29-1
    Published Updated
  8. CVE-2016-4608

    Critical · CVSS 9.8EPSS 4.92%Fix available

    CVE-2016-4608

    libxslt in Apple iOS before 9.3.3, OS X before 10.11.6, iTunes before 12.4.2 on Windows, iCloud before 5.2.1 on Windows, tvOS before 9.2.2, and watchOS before 2.2.2 allows remote attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact via unknown vectors, a different vulnerability than CVE-2016-4607, CVE-2016-4609, CVE-2016-4610, and CVE-2016-4612.

    • Update to 1.1.29-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →