p PatchFirst

CVE-2012-6708

CVE-2012-6708

This page contains facts from public vulnerability sources. Check the original advisory before updating.

jQuery before 1.9.0 is vulnerable to Cross-site Scripting (XSS) attacks. The jQuery(strInput) function does not differentiate selectors from HTML in a reliable fashion. In vulnerable versions, jQuery determined whether the input was HTML by looking for the '<' character anywhere in the string, giving attackers more flexibility when attempting to construct a malicious payload. In fixed versions, jQuery only deems the input to be HTML if it explicitly starts with the '<' character, limiting exploitability only to attackers who can control the beginning of a string, which is far less common.

CVSS 6.1 · Medium · EPSS 8.6% · Public exploit · Fix available

Published
Updated

Stack: system · node

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • jquery npm

    Affected ranges
    • SEMVER: < 1.9.0

    Update to 1.9.0

  • org.webjars.npm:jquery Maven

    Versions
    • 1.7.2
    • 1.7.3
    • 1.8.2
    • 1.8.3
    Affected ranges
    • ECOSYSTEM: < 1.9.0

    Update to 1.9.0

  • jquery NuGet

    Versions
    • 1.4.1
    • 1.4.2
    • 1.4.3
    • 1.4.4
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.6.0
    • 1.6.1
    • 1.6.2
    • 1.6.3
    • 1.6.4
    • 1.7.0
    • 1.7.1
    • 1.7.1.1
    • 1.7.2
    • 1.8.0
    • 1.8.1
    • 1.8.2
    • 1.8.3
    Affected ranges
    • ECOSYSTEM: < 1.9.0

    Update to 1.9.0

  • jquery-rails RubyGems

    Versions
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.2
    • 0.2.1
    • 0.2.2
    • 0.2.3
    • 0.2.4
    • 0.2.5
    • 0.2.6
    • 0.2.7
    • 1.0
    • 1.0.1
    • 1.0.10
    • 1.0.11
    • 1.0.12
    • 1.0.13
    • 1.0.14
    • 1.0.15
    • 1.0.16
    • 1.0.17
    • 1.0.18
    • 1.0.19
    • 1.0.2
    • 1.0.3
    • 1.0.4
    • 1.0.5
    • 1.0.6
    • 1.0.7
    • 1.0.8
    • 1.0.9
    • 1.0.rc
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 2.1.0
    • 2.1.1
    • 2.1.2
    • 2.1.3
    • 2.1.4
    Affected ranges
    • ECOSYSTEM: < 2.2.0

    Update to 2.2.0

  • jquery Ubuntu:Pro:14.04:LTS

    Versions
    • 1.7.2+dfsg-2ubuntu1
    Affected ranges
    • ECOSYSTEM: < 1.7.2+dfsg-2ubuntu1+esm1

    Update to 1.7.2+dfsg-2ubuntu1+esm1

Original sources

Check your server →