CVE-2013-2207
CVE-2013-2207
This page contains facts from public vulnerability sources. Check the original advisory before updating.
pt_chown in GNU C Library (aka glibc or libc6) before 2.18 does not properly check permissions for tty files, which allows local users to change the permission on the files and obtain access to arbitrary pseudo-terminals by leveraging a FUSE file system.
EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
glibc Debian:12
- Affected ranges
- ECOSYSTEM: < 2.21-1
Update to 2.21-1
glibc Debian:13
- Affected ranges
- ECOSYSTEM: < 2.21-1
Update to 2.21-1
glibc Debian:14
- Affected ranges
- ECOSYSTEM: < 2.21-1
Update to 2.21-1
eglibc Ubuntu:14.04:LTS
- Versions
- 2.17-93ubuntu4
- 2.18-0ubuntu1
- 2.18-0ubuntu2
- 2.18-0ubuntu4
- 2.18-0ubuntu5
- 2.18-0ubuntu6
- 2.18-0ubuntu7
- 2.19-0ubuntu2
- 2.19-0ubuntu3
- 2.19-0ubuntu4
- 2.19-0ubuntu5
- 2.19-0ubuntu6
- 2.19-0ubuntu6.1
- 2.19-0ubuntu6.3
- 2.19-0ubuntu6.4
- 2.19-0ubuntu6.5
- 2.19-0ubuntu6.6
- 2.19-0ubuntu6.7
- Affected ranges
- ECOSYSTEM: < 2.19-0ubuntu6.8
Update to 2.19-0ubuntu6.8
Original sources
- https://sourceware.org/bugzilla/show_bug.cgi?id=15755
- http://secunia.com/advisories/55113
- http://lists.opensuse.org/opensuse-security-announce/2015-08/msg00019.html
- https://sourceware.org/ml/libc-alpha/2013-08/msg00160.html
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00036.html
- http://www.ubuntu.com/usn/USN-2985-2
- https://bugzilla.redhat.com/show_bug.cgi?id=976408
- https://security.gentoo.org/glsa/201503-04
- http://www.mandriva.com/security/advisories?name=MDVSA-2013:283
- http://www.ubuntu.com/usn/USN-2985-1
- https://nvd.nist.gov/vuln/detail/CVE-2013-2207