p PatchFirst

PatchFirst · Latest vulnerabilities

eglibc vulnerabilities

Vulnerabilities published for eglibc in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 34

  1. CVE-2017-16997

    High · CVSS 7.8EPSS 2.9%Fix available

    CVE-2017-16997

    elf/dl-load.c in the GNU C Library (aka glibc or libc6) 2.19 through 2.26 mishandles RPATH and RUNPATH containing $ORIGIN for a privileged (setuid or AT_SECURE) program, which allows local users to gain privileges via a Trojan horse library in the current working directory, related to the fillin_rpath and decompose_rpath functions. This is associated with misinterpretion of an empty RPATH/RUNPATH token as the "./" directory. NOTE: this configuration of RPATH/RUNPATH for a privileged program is apparently very uncommon; most likely, no such program is shipped with any common Linux distribution.

    • Update to 2.19-0ubuntu6.14
    Published Updated
  2. CVE-2017-1000366

    High · CVSS 7.8EPSS 2.73%Public exploitFix available

    CVE-2017-1000366

    glibc contains a vulnerability that allows specially crafted LD_LIBRARY_PATH values to manipulate the heap/stack, causing them to alias, potentially resulting in arbitrary code execution. Please note that additional hardening changes have been made to glibc to prevent manipulation of stack and heap memory but these issues are not directly exploitable, as such they have not been given a CVE. This affects glibc 2.25 and earlier.

    • Update to 2.19-0ubuntu6.13
    Published Updated
  3. CVE-2015-8983

    High · CVSS 8.1EPSS 4.01%Fix available

    CVE-2015-8983

    Integer overflow in the _IO_wstr_overflow function in libio/wstrops.c in the GNU C Library (aka glibc or libc6) before 2.22 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via vectors related to computing a size in bytes, which triggers a heap-based buffer overflow.

    • Update to 2.19-0ubuntu6.10
    Published Updated
  4. CVE-2016-6323

    High · CVSS 7.5EPSS 3.87%Fix available

    CVE-2016-6323

    The makecontext function in the GNU C Library (aka glibc or libc6) before 2.25 creates execution contexts incompatible with the unwinder on ARM EABI (32-bit) platforms, which might allow context-dependent attackers to cause a denial of service (hang), as demonstrated by applications compiled using gccgo, related to backtrace generation.

    • Update to 2.19-0ubuntu6.10
    Published Updated
  5. CVE-2016-3706

    High · CVSS 7.5EPSS 5.93%Fix available

    CVE-2016-3706

    Stack-based buffer overflow in the getaddrinfo function in sysdeps/posix/getaddrinfo.c in the GNU C Library (aka glibc or libc6) allows remote attackers to cause a denial of service (crash) via vectors involving hostent conversion. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-4458.

    • Update to 2.19-0ubuntu6.10
    Published Updated
  6. CVE-2015-8778

    Critical · CVSS 9.8EPSS 5.74%Fix available

    CVE-2015-8778

    Integer overflow in the GNU C Library (aka glibc or libc6) before 2.23 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via the size argument to the __hcreate_r function, which triggers out-of-bounds heap-memory access.

    • Update to 2.19-0ubuntu6.8
    Published Updated
  7. CVE-2016-2856

    High · CVSS 8.4EPSS 1.03%Public exploitFix available

    CVE-2016-2856

    pt_chown in the glibc package before 2.19-18+deb8u4 on Debian jessie; the elibc package before 2.15-0ubuntu10.14 on Ubuntu 12.04 LTS and before 2.19-0ubuntu6.8 on Ubuntu 14.04 LTS; and the glibc package before 2.21-0ubuntu4.2 on Ubuntu 15.10 and before 2.23-0ubuntu1 on Ubuntu 16.04 LTS and 16.10 lacks a namespace check associated with file-descriptor passing, which allows local users to capture keystrokes and spoof data, and possibly gain privileges, via pts read and write operations, related to debian/sysdeps/linux.mk. NOTE: this is not considered a vulnerability in the upstream GNU C Library because the upstream documentation has a clear s

    • Update to 2.19-0ubuntu6.8
    Published Updated
  8. CVE-2015-7547

    High · CVSS 8.1EPSS 90.99%Public exploitFix available

    CVE-2015-7547

    Multiple stack-based buffer overflows in the (1) send_dg and (2) send_vc functions in the libresolv library in the GNU C Library (aka glibc or libc6) before 2.23 allow remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted DNS response that triggers a call to the getaddrinfo function with the AF_UNSPEC or AF_INET6 address family, related to performing "dual A/AAAA DNS queries" and the libnss_dns.so.2 NSS module.

    • Update to 2.19-0ubuntu6.7
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →