p PatchFirst

CVE-2013-4116

CVE-2013-4116

This page contains facts from public vulnerability sources. Check the original advisory before updating.

lib/npm.js in Node Packaged Modules (npm) before 1.3.3 allows local users to overwrite arbitrary files via a symlink attack on temporary files with predictable names that are created when unpacking archives.

EPSS 0.4% · Fix available

Published
Updated

Stack: system · node

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • npm Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.3.10~dfsg-1

    Update to 1.3.10~dfsg-1

  • npm Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.3.10~dfsg-1

    Update to 1.3.10~dfsg-1

  • npm Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.3.10~dfsg-1

    Update to 1.3.10~dfsg-1

  • npm npm

    Affected ranges
    • SEMVER: < 1.3.3

    Update to 1.3.3

Original sources

Check your server →