p PatchFirst

PatchFirst · Latest vulnerabilities

npm vulnerabilities

Vulnerabilities published for npm in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 11

  1. CVE-2026-9496

    High · CVSS 8.7EPSS 0.35%Fix available

    CVE-2026-9496

    Versions of the package pacote from 11.2.7 and before 21.5.1 are vulnerable to Denial of Service (DoS) via the addGitSha function. An attacker can exploit this vulnerability by supplying a specially crafted spec.rawSpec value that triggers the function’s regex replacement and string-manipulation logic, causing excessive CPU consumption and potentially stalling or crashing the process.

    • Update to 12.0.2+ds1-1
    Published Updated
  2. CVE-2026-0775

    High · CVSS 7EPSS 0.29%No fix published

    npm cli Incorrect Permission Assignment Local Privilege Escalation Vulnerability

    npm cli Incorrect Permission Assignment Local Privilege Escalation Vulnerability. This vulnerability allows local attackers to escalate privileges on affected installations of npm cli. An attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability. The specific flaw exists within the handling of modules. The application loads modules from an unsecured location. An attacker can leverage this vulnerability to escalate privileges and execute arbitrary code in the context of a target user. Was ZDI-CAN-25430.

    Published Updated
  3. CVE-2021-43616

    Critical · CVSS 9EPSS 2.72%Fix available

    CVE-2021-43616

    The npm ci command in npm 7.x and 8.x through 8.1.3 proceeds with an installation even if dependency information in package-lock.json differs from package.json. This behavior is inconsistent with the documentation, and makes it easier for attackers to install malware that was supposed to have been blocked by an exact version match requirement in package-lock.json. NOTE: The npm team believes this is not a vulnerability. It would require someone to socially engineer package.json which has different dependencies than package-lock.json. That user would have to have file system or write access to change dependencies. The npm team states preventin

    • Update to 8.4.1~ds-1
    Published Updated
  4. CVE-2021-39135

    High · CVSS 8.2EPSS 0.56%Fix available

    UNIX Symbolic Link (Symlink) Following in @npmcli/arborist

    `@npmcli/arborist`, the library that calculates dependency trees and manages the node_modules folder hierarchy for the npm command line interface, aims to guarantee that package dependency contracts will be met, and the extraction of package contents will always be performed into the expected folder. This is accomplished by extracting package contents into a project's `node_modules` folder. If the `node_modules` folder of the root project or any of its dependencies is somehow replaced with a symbolic link, it could allow Arborist to write package dependencies to any arbitrary location on the file system. Note that symbolic links contained wit

    • Update to 7.24.0+ds-2
    Published Updated
  5. CVE-2021-39134

    High · CVSS 8.2EPSS 0.59%Fix available

    UNIX Symbolic Link (Symlink) Following in @npmcli/arborist

    `@npmcli/arborist`, the library that calculates dependency trees and manages the `node_modules` folder hierarchy for the npm command line interface, aims to guarantee that package dependency contracts will be met, and the extraction of package contents will always be performed into the expected folder. This is, in part, accomplished by resolving dependency specifiers defined in `package.json` manifests for dependencies with a specific name, and nesting folders to resolve conflicting dependencies. When multiple dependencies differ only in the case of their name, Arborist's internal data structure saw them as separate items that could coexist w

    • Update to 7.24.0+ds-2
    Published Updated
  6. CVE-2020-15095

    Medium · CVSS 4.4EPSS 0.4%Fix available

    Sensitive information exposure through logs in npm cli

    Versions of the npm CLI prior to 6.14.6 are vulnerable to an information exposure vulnerability through log files. The CLI supports URLs like "<protocol>://[<user>[:<password>]@]<hostname>[:<port>][:][/]<path>". The password value is not redacted and is printed to stdout and also to any generated log files.

    • Update to 6.14.6+ds-1
    Published Updated
  7. CVE-2019-16777

    High · CVSS 7.7EPSS 2.13%Fix available

    Arbitrary File Overwrite in npm CLI

    Versions of the npm CLI prior to 6.13.4 are vulnerable to an Arbitrary File Overwrite. It fails to prevent existing globally-installed binaries to be overwritten by other package installations. For example, if a package was installed globally and created a serve binary, any subsequent installs of packages that also create a serve binary would overwrite the previous serve binary. This behavior is still allowed in local installations and also through install scripts. This vulnerability bypasses a user using the --ignore-scripts install option.

    • Update to 6.13.4+ds-2
    Published Updated
  8. CVE-2019-16776

    High · CVSS 7.7EPSS 3.42%Fix available

    Unauthorized File Access in npm CLI before before version 6.13.3

    Versions of the npm CLI prior to 6.13.3 are vulnerable to an Arbitrary File Write. It fails to prevent access to folders outside of the intended node_modules folder through the bin field. A properly constructed entry in the package.json bin field would allow a package publisher to modify and/or gain access to arbitrary files on a user's system when the package is installed. This behavior is still possible through install scripts. This vulnerability bypasses a user using the --ignore-scripts install option.

    • Update to 6.13.4+ds-2
    Published Updated
  9. CVE-2019-16775

    High · CVSS 7.7EPSS 3.33%Fix available

    Unauthorized File Access in npm CLI before before version 6.13.3

    Versions of the npm CLI prior to 6.13.3 are vulnerable to an Arbitrary File Write. It is possible for packages to create symlinks to files outside of thenode_modules folder through the bin field upon installation. A properly constructed entry in the package.json bin field would allow a package publisher to create a symlink pointing to arbitrary files on a user's system when the package is installed. This behavior is still possible through install scripts. This vulnerability bypasses a user using the --ignore-scripts install option.

    • Update to 6.13.4+ds-2
    Published Updated
  10. CVE-2016-3956

    High · CVSS 7.5EPSS 5.46%Fix available

    CVE-2016-3956

    The CLI in npm before 2.15.1 and 3.x before 3.8.3, as used in Node.js 0.10 before 0.10.44, 0.12 before 0.12.13, 4 before 4.4.2, and 5 before 5.10.0, includes bearer tokens with arbitrary requests, which allows remote HTTP servers to obtain sensitive information by reading Authorization headers.

    • Update to 5.8.0+ds-2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →