p PatchFirst

CVE-2013-4164

CVE-2013-4164

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Heap-based buffer overflow in Ruby 1.8, 1.9 before 1.9.3-p484, 2.0 before 2.0.0-p353, 2.1 before 2.1.0 preview2, and trunk before revision 43780 allows context-dependent attackers to cause a denial of service (segmentation fault) and possibly execute arbitrary code via a string that is converted to a floating point value, as demonstrated using (1) the to_f method or (2) JSON.parse.

EPSS 35.0% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ruby1.9.1 Ubuntu:14.04:LTS

    Versions
    • 1.9.3.194-8.1ubuntu2
    • 1.9.3.448-1ubuntu1
    Affected ranges
    • ECOSYSTEM: < 1.9.3.448-1ubuntu2

    Update to 1.9.3.448-1ubuntu2

  • ruby2.0 Ubuntu:14.04:LTS

    Versions
    • 2.0.0.299-2
    • 2.0.0.343-1
    Affected ranges
    • ECOSYSTEM: < 2.0.0.343-1ubuntu1

    Update to 2.0.0.343-1ubuntu1

Original sources

Check your server →