p PatchFirst

PatchFirst · Latest vulnerabilities

ruby1.9.1 vulnerabilities

Vulnerabilities published for ruby1.9.1 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 37

  1. CVE-2015-1855

    Medium · CVSS 5.9EPSS 2.81%Fix available

    CVE-2015-1855

    verify_certificate_identity in the OpenSSL extension in Ruby before 2.0.0 patchlevel 645, 2.1.x before 2.1.6, and 2.2.x before 2.2.2 does not properly validate hostnames, which allows remote attackers to spoof servers via vectors related to (1) multiple wildcards, (1) wildcards in IDNA names, (3) case sensitivity, and (4) non-ASCII characters.

    • Update to 1.9.3.484-2ubuntu1.3
    Published Updated
  2. CVE-2019-8324

    High · CVSS 8.8EPSS 3.22%Fix available

    CVE-2019-8324

    An issue was discovered in RubyGems 2.6 and later through 3.0.2. A crafted gem with a multi-line name is not handled correctly. Therefore, an attacker could inject arbitrary code to the stub line of gemspec, which is eval-ed by code in ensure_loadable_spec during the preinstall check.

    • Update to 1.9.3.484-2ubuntu1.14
    Published Updated
  3. CVE-2019-8320

    High · CVSS 7.4EPSS 4.19%Fix available

    CVE-2019-8320

    A Directory Traversal issue was discovered in RubyGems 2.7.6 and later through 3.0.2. Before making new directories or touching files (which now include path-checking code for symlinks), it would delete the target destination. If that destination was hidden behind a symlink, a malicious gem could delete arbitrary files on the user's machine, presuming the attacker could guess at paths. Given how frequently gem is run as sudo, and how predictable paths are on modern systems (/tmp, /usr, etc.), this could likely lead to data loss or an unusable system.

    • Update to 1.9.3.484-2ubuntu1.14
    Published Updated
  4. CVE-2018-16395

    Critical · CVSS 9.8EPSS 10.71%Fix available

    CVE-2018-16395

    An issue was discovered in the OpenSSL library in Ruby before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.2, and 2.6.x before 2.6.0-preview3. When two OpenSSL::X509::Name objects are compared using ==, depending on the ordering, non-equal objects may return true. When the first argument is one character longer than the second, or the second argument contains a character that is one less than a character in the same position of the first argument, the result of == will be true. This could be leveraged to create an illegitimate certificate that may be accepted as legitimate and then used in signing or encryption operations.

    • Update to 1.9.3.484-2ubuntu1.13
    Published Updated
  5. CVE-2018-8780

    Critical · CVSS 9.1EPSS 9.98%Fix available

    CVE-2018-8780

    In Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1, the Dir.open, Dir.new, Dir.entries and Dir.empty? methods do not check NULL characters. When using the corresponding method, unintentional directory traversal may be performed.

    • Update to 1.9.3.484-2ubuntu1.11
    Published Updated
  6. CVE-2018-8778

    High · CVSS 7.5EPSS 7.53%Fix available

    CVE-2018-8778

    In Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1, an attacker controlling the unpacking format (similar to format string vulnerabilities) can trigger a buffer under-read in the String#unpack method, resulting in a massive and controlled information disclosure.

    • Update to 1.9.3.484-2ubuntu1.11
    Published Updated
  7. CVE-2018-8777

    High · CVSS 7.5EPSS 4.46%Fix available

    CVE-2018-8777

    In Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1, an attacker can pass a large HTTP request with a crafted header to WEBrick server or a crafted body to WEBrick server/handler and cause a denial of service (memory consumption).

    • Update to 1.9.3.484-2ubuntu1.12
    Published Updated
  8. CVE-2018-6914

    High · CVSS 7.5EPSS 10.16%Fix available

    CVE-2018-6914

    Directory traversal vulnerability in the Dir.mktmpdir method in the tmpdir library in Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1 might allow attackers to create arbitrary directories or files via a .. (dot dot) in the prefix argument.

    • Update to 1.9.3.484-2ubuntu1.11
    Published Updated
  9. CVE-2018-1000078

    Medium · CVSS 6.1EPSS 2.75%Fix available

    CVE-2018-1000078

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Cross Site Scripting (XSS) vulnerability in gem server display of homepage attribute that can result in XSS. This attack appear to be exploitable via the victim must browse to a malicious gem on a vulnerable gem server. This vulnerability appears to have been fixed in 2.7.6.

    • Update to 1.9.3.484-2ubuntu1.8
    Published Updated
  10. CVE-2018-1000077

    Medium · CVSS 5.3EPSS 3.6%Fix available

    CVE-2018-1000077

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Improper Input Validation vulnerability in ruby gems specification homepage attribute that can result in a malicious gem could set an invalid homepage URL. This vulnerability appears to have been fixed in 2.7.6.

    • Update to 1.9.3.484-2ubuntu1.8
    Published Updated
  11. CVE-2018-1000075

    High · CVSS 7.5EPSS 4.74%Fix available

    CVE-2018-1000075

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a infinite loop caused by negative size vulnerability in ruby gem package tar header that can result in a negative size could cause an infinite loop.. This vulnerability appears to have been fixed in 2.7.6.

    • Update to 1.9.3.484-2ubuntu1.8
    Published Updated
  12. CVE-2018-1000074

    High · CVSS 7.8EPSS 2.88%Fix available

    CVE-2018-1000074

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Deserialization of Untrusted Data vulnerability in owner command that can result in code execution. This attack appear to be exploitable via victim must run the `gem owner` command on a gem with a specially crafted YAML file. This vulnerability appears to have been fixed in 2.7.6.

    • Update to 1.9.3.484-2ubuntu1.12
    Published Updated
  13. CVE-2017-17790

    Critical · CVSS 9.8EPSS 5.91%Fix available

    CVE-2017-17790

    The lazy_initialize function in lib/resolv.rb in Ruby through 2.4.3 uses Kernel#open, which might allow Command Injection attacks, as demonstrated by a Resolv::Hosts::new argument beginning with a '|' character, a different vulnerability than CVE-2017-17405. NOTE: situations with untrusted input may be highly unlikely.

    • Update to 1.9.3.484-2ubuntu1.7
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →