CVE-2014-0062
CVE-2014-0062
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Race condition in the (1) CREATE INDEX and (2) unspecified ALTER TABLE commands in PostgreSQL before 8.4.20, 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3 allows remote authenticated users to create an unauthorized index or read portions of unauthorized tables by creating or deleting a table with the same name during the timing window.
EPSS 3.0% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
postgresql-9.1 Ubuntu:14.04:LTS
- Versions
- 9.1.10-1
- 9.1.10-1bzr1
- 9.1.11-1
- 9.1.11-2
- Affected ranges
- ECOSYSTEM: < 9.1.12-1
Update to 9.1.12-1
postgresql-9.3 Ubuntu:14.04:LTS
- Versions
- 9.3.1-1
- 9.3.2-1
- 9.3.2-1ubuntu1
- 9.3.2-1ubuntu2
- Affected ranges
- ECOSYSTEM: < 9.3.3-1
Update to 9.3.3-1
Original sources
- http://rhn.redhat.com/errata/RHSA-2014-0211.html
- http://rhn.redhat.com/errata/RHSA-2014-0221.html
- http://support.apple.com/kb/HT6448
- http://rhn.redhat.com/errata/RHSA-2014-0469.html
- http://archives.neohapsis.com/archives/bugtraq/2014-10/0103.html
- http://wiki.postgresql.org/wiki/20140220securityrelease
- http://www.debian.org/security/2014/dsa-2864
- http://www.oracle.com/technetwork/security-advisory/cpuoct2017-3236626.html
- http://rhn.redhat.com/errata/RHSA-2014-0249.html
- http://www.securityfocus.com/bid/65727
- http://www.postgresql.org/about/news/1506/
- http://www.ubuntu.com/usn/USN-2120-1
- https://support.apple.com/kb/HT6536
- http://www.debian.org/security/2014/dsa-2865
- http://lists.opensuse.org/opensuse-updates/2014-03/msg00018.html
- http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10705
- http://lists.opensuse.org/opensuse-updates/2014-03/msg00038.html
- http://secunia.com/advisories/61307
- https://nvd.nist.gov/vuln/detail/CVE-2014-0062