p PatchFirst

PatchFirst · Latest vulnerabilities

postgresql-9.3 vulnerabilities

Vulnerabilities published for postgresql-9.3 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 31

  1. CVE-2015-0241

    High · CVSS 8.8EPSS 5.53%Fix available

    CVE-2015-0241

    The to_char function in PostgreSQL before 9.0.19, 9.1.x before 9.1.15, 9.2.x before 9.2.10, 9.3.x before 9.3.6, and 9.4.x before 9.4.1 allows remote authenticated users to cause a denial of service (crash) or possibly execute arbitrary code via a (1) large number of digits when processing a numeric formatting template, which triggers a buffer over-read, or (2) crafted timestamp formatting template, which triggers a buffer overflow.

    • Update to 9.3.6-0ubuntu0.14.04
    Published Updated
  2. CVE-2015-0243

    High · CVSS 8.8EPSS 5.12%Fix available

    CVE-2015-0243

    Multiple buffer overflows in contrib/pgcrypto in PostgreSQL before 9.0.19, 9.1.x before 9.1.15, 9.2.x before 9.2.10, 9.3.x before 9.3.6, and 9.4.x before 9.4.1 allow remote authenticated users to cause a denial of service (crash) and possibly execute arbitrary code via unspecified vectors.

    • Update to 9.3.6-0ubuntu0.14.04
    Published Updated
  3. CVE-2015-0244

    Critical · CVSS 9.8EPSS 4.36%Fix available

    CVE-2015-0244

    PostgreSQL before 9.0.19, 9.1.x before 9.1.15, 9.2.x before 9.2.10, 9.3.x before 9.3.6, and 9.4.x before 9.4.1 does not properly handle errors while reading a protocol message, which allows remote attackers to conduct SQL injection attacks via crafted binary data in a parameter and causing an error, which triggers the loss of synchronization and part of the protocol message to be treated as a new message, as demonstrated by causing a timeout or query cancellation.

    • Update to 9.3.6-0ubuntu0.14.04
    Published Updated
  4. CVE-2015-3166

    Critical · CVSS 9.8EPSS 4.61%Fix available

    CVE-2015-3166

    The snprintf implementation in PostgreSQL before 9.0.20, 9.1.x before 9.1.16, 9.2.x before 9.2.11, 9.3.x before 9.3.7, and 9.4.x before 9.4.2 does not properly handle system-call errors, which allows attackers to obtain sensitive information or have other unspecified impact via unknown vectors, as demonstrated by an out-of-memory error.

    • Update to 9.3.7-0ubuntu0.14.04
    Published Updated
  5. CVE-2015-3167

    High · CVSS 7.5EPSS 4.13%Fix available

    CVE-2015-3167

    contrib/pgcrypto in PostgreSQL before 9.0.20, 9.1.x before 9.1.16, 9.2.x before 9.2.11, 9.3.x before 9.3.7, and 9.4.x before 9.4.2 uses different error responses when an incorrect key is used, which makes it easier for attackers to obtain the key via a brute force attack.

    • Update to 9.3.7-0ubuntu0.14.04
    Published Updated
  6. CVE-2018-10915

    High · CVSS 8.5EPSS 5.09%Fix available

    CVE-2018-10915

    A vulnerability was found in libpq, the default PostgreSQL client library where libpq failed to properly reset its internal state between connections. If an affected version of libpq was used with "host" or "hostaddr" connection parameters from untrusted input, attackers could bypass client-side connection security features, obtain access to higher privileged connections or potentially cause other impact through SQL injection, by causing the PQescape() functions to malfunction. Postgresql versions before 10.5, 9.6.10, 9.5.14, 9.4.19, and 9.3.24 are affected.

    • Update to 9.3.24-0ubuntu0.14.04
    Published Updated
  7. CVE-2018-1053

    High · CVSS 7EPSS 0.48%Fix available

    CVE-2018-1053

    In postgresql 9.3.x before 9.3.21, 9.4.x before 9.4.16, 9.5.x before 9.5.11, 9.6.x before 9.6.7 and 10.x before 10.2, pg_upgrade creates file in current working directory containing the output of `pg_dumpall -g` under umask which was in effect when the user invoked pg_upgrade, and not under 0077 which is normally used for other temporary files. This can allow an authenticated attacker to read or modify the one file, which may contain encrypted or unencrypted database passwords. The attack is infeasible if a directory mode blocks the attacker searching the current working directory or if the prevailing umask blocks the attacker opening the fil

    • Update to 9.3.21-0ubuntu0.14.04
    Published Updated
  8. CVE-2017-7547

    High · CVSS 8.8EPSS 5.58%Fix available

    CVE-2017-7547

    PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are vulnerable to authorization flaw allowing remote authenticated attackers to retrieve passwords from the user mappings defined by the foreign server owners without actually having the privileges to do so.

    • Update to 9.3.18-0ubuntu0.14.04.1
    Published Updated
  9. CVE-2017-7485

    Medium · CVSS 5.9EPSS 2.04%Fix available

    CVE-2017-7485

    In PostgreSQL 9.3.x before 9.3.17, 9.4.x before 9.4.12, 9.5.x before 9.5.7, and 9.6.x before 9.6.3, it was found that the PGREQUIRESSL environment variable was no longer enforcing a SSL/TLS connection to a PostgreSQL server. An active Man-in-the-Middle attacker could use this flaw to strip the SSL/TLS protection from a connection between a client and a server.

    • Update to 9.3.17-0ubuntu0.14.04
    Published Updated
  10. CVE-2017-7484

    High · CVSS 7.5EPSS 2.56%Fix available

    CVE-2017-7484

    It was found that some selectivity estimation functions in PostgreSQL before 9.2.21, 9.3.x before 9.3.17, 9.4.x before 9.4.12, 9.5.x before 9.5.7, and 9.6.x before 9.6.3 did not check user privileges before providing information from pg_statistic, possibly leaking information. An unprivileged attacker could use this flaw to steal some information from tables they are otherwise not allowed to access.

    • Update to 9.3.17-0ubuntu0.14.04
    Published Updated
  11. CVE-2016-5424

    High · CVSS 7.1EPSS 4.61%Fix available

    CVE-2016-5424

    PostgreSQL before 9.1.23, 9.2.x before 9.2.18, 9.3.x before 9.3.14, 9.4.x before 9.4.9, and 9.5.x before 9.5.4 might allow remote authenticated users with the CREATEDB or CREATEROLE role to gain superuser privileges via a (1) " (double quote), (2) \ (backslash), (3) carriage return, or (4) newline character in a (a) database or (b) role name that is mishandled during an administrative operation.

    • Update to 9.3.14-0ubuntu0.14.04
    Published Updated
  12. CVE-2016-5423

    High · CVSS 8.3EPSS 5.96%Fix available

    CVE-2016-5423

    PostgreSQL before 9.1.23, 9.2.x before 9.2.18, 9.3.x before 9.3.14, 9.4.x before 9.4.9, and 9.5.x before 9.5.4 allow remote authenticated users to cause a denial of service (NULL pointer dereference and server crash), obtain sensitive memory information, or possibly execute arbitrary code via (1) a CASE expression within the test value subexpression of another CASE or (2) inlining of an SQL function that implements the equality operator used for a CASE expression involving values of different types.

    • Update to 9.3.14-0ubuntu0.14.04
    Published Updated
  13. CVE-2016-0773

    High · CVSS 7.5EPSS 6.95%Fix available

    CVE-2016-0773

    PostgreSQL before 9.1.20, 9.2.x before 9.2.15, 9.3.x before 9.3.11, 9.4.x before 9.4.6, and 9.5.x before 9.5.1 allows remote attackers to cause a denial of service (infinite loop or buffer overflow and crash) via a large Unicode character range in a regular expression.

    • Update to 9.3.11-0ubuntu0.14.04
    Published Updated
  14. CVE-2016-0766

    High · CVSS 8.8EPSS 4.11%Fix available

    CVE-2016-0766

    PostgreSQL before 9.1.20, 9.2.x before 9.2.15, 9.3.x before 9.3.11, 9.4.x before 9.4.6, and 9.5.x before 9.5.1 does not properly restrict access to unspecified custom configuration settings (GUCS) for PL/Java, which allows attackers to gain privileges via unspecified vectors.

    • Update to 9.3.11-0ubuntu0.14.04
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →