CVE-2014-0067
CVE-2014-0067
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The "make check" command for the test suites in PostgreSQL 9.3.3 and earlier does not properly invoke initdb to specify the authentication requirements for a database cluster to be used for the tests, which allows local users to gain privileges by leveraging access to this cluster.
EPSS 0.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
postgresql-9.1 Ubuntu:14.04:LTS
- Versions
- 9.1.10-1
- 9.1.10-1bzr1
- 9.1.11-1
- 9.1.11-2
- 9.1.12-1
- 9.1.13-1
- 9.1.14-0ubuntu0.14.04
- Affected ranges
- ECOSYSTEM: < 9.1.15-0ubuntu0.14.04
Update to 9.1.15-0ubuntu0.14.04
postgresql-9.3 Ubuntu:14.04:LTS
- Versions
- 9.3.1-1
- 9.3.2-1
- 9.3.2-1ubuntu1
- 9.3.2-1ubuntu2
- 9.3.3-1
- 9.3.3-1bzr1
- 9.3.3-1bzr2
- 9.3.4-1
- Affected ranges
- ECOSYSTEM: < 9.3.5-0ubuntu0.14.04.1
Update to 9.3.5-0ubuntu0.14.04.1
Original sources
- http://wiki.postgresql.org/wiki/20140220securityrelease
- http://www.debian.org/security/2014/dsa-2864
- http://www.postgresql.org/about/news/1506/
- http://lists.apple.com/archives/security-announce/2015/Aug/msg00001.html
- http://www.debian.org/security/2014/dsa-2865
- http://lists.opensuse.org/opensuse-updates/2014-03/msg00018.html
- http://www.securityfocus.com/bid/65721
- https://support.apple.com/kb/HT205031
- http://lists.apple.com/archives/security-announce/2015/Sep/msg00004.html
- http://lists.opensuse.org/opensuse-updates/2014-03/msg00038.html
- https://support.apple.com/HT205219
- https://nvd.nist.gov/vuln/detail/CVE-2014-0067