p PatchFirst

CVE-2014-0475

CVE-2014-0475

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Multiple directory traversal vulnerabilities in GNU C Library (aka glibc or libc6) before 2.20 allow context-dependent attackers to bypass ForceCommand restrictions and possibly have other unspecified impact via a .. (dot dot) in a (1) LC_*, (2) LANG, or other locale environment variable.

EPSS 2.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • glibc Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.19-6

    Update to 2.19-6

  • glibc Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.19-6

    Update to 2.19-6

  • glibc Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.19-6

    Update to 2.19-6

  • eglibc Ubuntu:14.04:LTS

    Versions
    • 2.17-93ubuntu4
    • 2.18-0ubuntu1
    • 2.18-0ubuntu2
    • 2.18-0ubuntu4
    • 2.18-0ubuntu5
    • 2.18-0ubuntu6
    • 2.18-0ubuntu7
    • 2.19-0ubuntu2
    • 2.19-0ubuntu3
    • 2.19-0ubuntu4
    • 2.19-0ubuntu5
    • 2.19-0ubuntu6
    Affected ranges
    • ECOSYSTEM: < 2.19-0ubuntu6.1

    Update to 2.19-0ubuntu6.1

Original sources

Check your server →