p PatchFirst

CVE-2014-1544

CVE-2014-1544

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Use-after-free vulnerability in the CERT_DestroyCertificate function in libnss3.so in Mozilla Network Security Services (NSS) 3.x, as used in Firefox before 31.0, Firefox ESR 24.x before 24.7, and Thunderbird before 24.7, allows remote attackers to execute arbitrary code via vectors that trigger certain improper removal of an NSSCertificate structure from a trust domain.

EPSS 6.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • nss Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:3.16.3-1

    Update to 2:3.16.3-1

  • nss Debian:13

    Affected ranges
    • ECOSYSTEM: < 2:3.16.3-1

    Update to 2:3.16.3-1

  • nss Debian:14

    Affected ranges
    • ECOSYSTEM: < 2:3.16.3-1

    Update to 2:3.16.3-1

  • firefox Ubuntu:14.04:LTS

    Versions
    • 24.0+build1-0ubuntu1
    • 25.0+build3-0ubuntu0.13.10.1
    • 28.0~b2+build1-0ubuntu2
    • 28.0+build1-0ubuntu1
    • 28.0+build2-0ubuntu1
    • 28.0+build2-0ubuntu2
    • 29.0+build1-0ubuntu0.14.04.2
    • 30.0+build1-0ubuntu0.14.04.3
    Affected ranges
    • ECOSYSTEM: < 31.0+build1-0ubuntu0.14.04.1

    Update to 31.0+build1-0ubuntu0.14.04.1

  • nss Ubuntu:14.04:LTS

    Versions
    • 2:3.15.1-1ubuntu1
    • 2:3.15.2-1
    • 2:3.15.3-1
    • 2:3.15.3.1-1
    • 2:3.15.3.1-1.1
    • 2:3.15.3.1-1.1ubuntu1
    • 2:3.15.4-1ubuntu3
    • 2:3.15.4-1ubuntu4
    • 2:3.15.4-1ubuntu5
    • 2:3.15.4-1ubuntu6
    • 2:3.15.4-1ubuntu7
    Affected ranges
    • ECOSYSTEM: < 2:3.15.4-1ubuntu7.1

    Update to 2:3.15.4-1ubuntu7.1

  • thunderbird Ubuntu:14.04:LTS

    Versions
    • 1:24.0+build1-0ubuntu1
    • 1:24.0+build1-0ubuntu2
    • 1:24.1.1+build1-0ubuntu0.13.10.1
    • 1:24.1.1+build1-0ubuntu1
    • 1:24.2.0+build1-0ubuntu1
    • 1:24.4.0+build1-0ubuntu1
    • 1:24.5.0+build1-0ubuntu0.14.04.1
    • 1:24.6.0+build1-0ubuntu0.14.04.1
    Affected ranges
    • ECOSYSTEM: < 1:31.0+build1-0ubuntu0.14.04.1

    Update to 1:31.0+build1-0ubuntu0.14.04.1

Original sources

Check your server →