p PatchFirst

PatchFirst · Latest vulnerabilities

thunderbird vulnerabilities

Vulnerabilities published for thunderbird in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 341

  1. CVE-2019-9796

    Critical · CVSS 9.8EPSS 2.06%Fix available

    CVE-2019-9796

    A use-after-free vulnerability can occur when the SMIL animation controller incorrectly registers with the refresh driver twice when only a single registration is expected. When a registration is later freed with the removal of the animation controller element, the refresh driver incorrectly leaves a dangling pointer to the driver's observer array. This vulnerability affects Thunderbird < 60.6, Firefox ESR < 60.6, and Firefox < 66.

    • Update to 1:60.6.1+build2-0ubuntu0.14.04.1
    Published Updated
  2. CVE-2019-9795

    Critical · CVSS 9.8EPSS 1.7%Fix available

    CVE-2019-9795

    A vulnerability where type-confusion in the IonMonkey just-in-time (JIT) compiler could potentially be used by malicious JavaScript to trigger a potentially exploitable crash. This vulnerability affects Thunderbird < 60.6, Firefox ESR < 60.6, and Firefox < 66.

    • Update to 1:60.6.1+build2-0ubuntu0.14.04.1
    Published Updated
  3. CVE-2019-9793

    Medium · CVSS 5.9EPSS 1.63%Fix available

    CVE-2019-9793

    A mechanism was discovered that removes some bounds checking for string, array, or typed array accesses if Spectre mitigations have been disabled. This vulnerability could allow an attacker to create an arbitrary value in compiled JavaScript, for which the range analysis will infer a fully controlled, incorrect range in circumstances where users have explicitly disabled Spectre mitigations. *Note: Spectre mitigations are currently enabled for all users by default settings.*. This vulnerability affects Thunderbird < 60.6, Firefox ESR < 60.6, and Firefox < 66.

    • Update to 1:60.6.1+build2-0ubuntu0.14.04.1
    Published Updated
  4. CVE-2019-9792

    Critical · CVSS 9.8EPSS 13.3%Public exploitFix available

    CVE-2019-9792

    The IonMonkey just-in-time (JIT) compiler can leak an internal JS_OPTIMIZED_OUT magic value to the running script during a bailout. This magic value can then be used by JavaScript to achieve memory corruption, which results in a potentially exploitable crash. This vulnerability affects Thunderbird < 60.6, Firefox ESR < 60.6, and Firefox < 66.

    • Update to 1:60.6.1+build2-0ubuntu0.14.04.1
    Published Updated
  5. CVE-2019-9791

    Critical · CVSS 9.8EPSS 19.91%Public exploitFix available

    CVE-2019-9791

    The type inference system allows the compilation of functions that can cause type confusions between arbitrary objects when compiled through the IonMonkey just-in-time (JIT) compiler and when the constructor function is entered through on-stack replacement (OSR). This allows for possible arbitrary reading and writing of objects during an exploitable crash. This vulnerability affects Thunderbird < 60.6, Firefox ESR < 60.6, and Firefox < 66.

    • Update to 1:60.6.1+build2-0ubuntu0.14.04.1
    Published Updated
  6. CVE-2019-9790

    Critical · CVSS 9.8EPSS 1.85%Fix available

    CVE-2019-9790

    A use-after-free vulnerability can occur when a raw pointer to a DOM element on a page is obtained using JavaScript and the element is then removed while still in use. This results in a potentially exploitable crash. This vulnerability affects Thunderbird < 60.6, Firefox ESR < 60.6, and Firefox < 66.

    • Update to 1:60.6.1+build2-0ubuntu0.14.04.1
    Published Updated
  7. CVE-2019-9788

    Critical · CVSS 9.8EPSS 2.24%Fix available

    CVE-2019-9788

    Mozilla developers and community members reported memory safety bugs present in Firefox 65, Firefox ESR 60.5, and Thunderbird 60.5. Some of these bugs showed evidence of memory corruption and we presume that with enough effort that some of these could be exploited to run arbitrary code. This vulnerability affects Thunderbird < 60.6, Firefox ESR < 60.6, and Firefox < 66.

    • Update to 1:60.6.1+build2-0ubuntu0.14.04.1
    Published Updated
  8. CVE-2018-18509

    Medium · CVSS 5.3EPSS 1.68%Fix available

    CVE-2018-18509

    A flaw during verification of certain S/MIME signatures causes emails to be shown in Thunderbird as having a valid digital signature, even if the shown message contents aren't covered by the signature. The flaw allows an attacker to reuse a valid S/MIME signature to craft an email message with arbitrary content. This vulnerability affects Thunderbird < 60.5.1.

    • Update to 1:60.5.1+build2-0ubuntu0.14.04.1
    Published Updated
  9. CVE-2018-18499

    Medium · CVSS 6.5EPSS 1.09%Fix available

    CVE-2018-18499

    A same-origin policy violation allowing the theft of cross-origin URL entries when using a meta http-equiv="refresh" on a page to cause a redirection to another site using performance.getEntries(). This is a same-origin policy violation and could allow for data theft. This vulnerability affects Firefox < 62, Firefox ESR < 60.2, and Thunderbird < 60.2.1.

    • Update to 1:60.2.1+build1-0ubuntu0.14.04.2
    Published Updated
  10. CVE-2018-18498

    Critical · CVSS 9.8EPSS 4.03%Fix available

    CVE-2018-18498

    A potential vulnerability leading to an integer overflow can occur during buffer size calculations for images when a raw value is used instead of the checked value. This leads to a possible out-of-bounds write. This vulnerability affects Thunderbird < 60.4, Firefox ESR < 60.4, and Firefox < 64.

    • Update to 1:60.4.0+build2-0ubuntu0.14.04.1
    Published Updated
  11. CVE-2018-18494

    Medium · CVSS 6.5EPSS 1.55%Fix available

    CVE-2018-18494

    A same-origin policy violation allowing the theft of cross-origin URL entries when using the Javascript location property to cause a redirection to another site using performance.getEntries(). This is a same-origin policy violation and could allow for data theft. This vulnerability affects Thunderbird < 60.4, Firefox ESR < 60.4, and Firefox < 64.

    • Update to 1:60.4.0+build2-0ubuntu0.14.04.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →