CVE-2014-1594
CVE-2014-1594
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Mozilla Firefox before 34.0, Firefox ESR 31.x before 31.3, Thunderbird before 31.3, and SeaMonkey before 2.31 might allow remote attackers to execute arbitrary code by leveraging an incorrect cast from the BasicThebesLayer data type to the BasicContainerLayer data type.
EPSS 3.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
firefox Ubuntu:14.04:LTS
- Versions
- 24.0+build1-0ubuntu1
- 25.0+build3-0ubuntu0.13.10.1
- 28.0~b2+build1-0ubuntu2
- 28.0+build1-0ubuntu1
- 28.0+build2-0ubuntu1
- 28.0+build2-0ubuntu2
- 29.0+build1-0ubuntu0.14.04.2
- 30.0+build1-0ubuntu0.14.04.3
- 31.0+build1-0ubuntu0.14.04.1
- 32.0+build1-0ubuntu0.14.04.1
- 32.0.3+build1-0ubuntu0.14.04.1
- 33.0+build2-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 34.0+build2-0ubuntu0.14.04.1
Update to 34.0+build2-0ubuntu0.14.04.1
thunderbird Ubuntu:14.04:LTS
- Versions
- 1:24.0+build1-0ubuntu1
- 1:24.0+build1-0ubuntu2
- 1:24.1.1+build1-0ubuntu0.13.10.1
- 1:24.1.1+build1-0ubuntu1
- 1:24.2.0+build1-0ubuntu1
- 1:24.4.0+build1-0ubuntu1
- 1:24.5.0+build1-0ubuntu0.14.04.1
- 1:24.6.0+build1-0ubuntu0.14.04.1
- 1:31.0+build1-0ubuntu0.14.04.1
- 1:31.1.1+build1-0ubuntu0.14.04.1
- 1:31.1.2+build1-0ubuntu0.14.04.1
- 1:31.2.0+build2-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 1:31.3.0+build1-0ubuntu0.14.04.1
Update to 1:31.3.0+build1-0ubuntu0.14.04.1
Original sources
- http://lists.opensuse.org/opensuse-security-announce/2015-01/msg00024.html
- https://security.gentoo.org/glsa/201504-01
- http://www.securityfocus.com/bid/71396
- https://bugzilla.mozilla.org/show_bug.cgi?id=1074280
- http://www.oracle.com/technetwork/topics/security/bulletinapr2015-2511959.html
- http://www.debian.org/security/2014/dsa-3090
- http://www.mozilla.org/security/announce/2014/mfsa2014-89.html
- http://lists.opensuse.org/opensuse-security-announce/2015-07/msg00031.html
- http://www.debian.org/security/2014/dsa-3092
- https://nvd.nist.gov/vuln/detail/CVE-2014-1594