CVE-2014-3497
CVE-2014-3497
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Cross-site scripting (XSS) vulnerability in OpenStack Swift 1.11.0 through 1.13.1 allows remote attackers to inject arbitrary web script or HTML via the WWW-Authenticate header.
EPSS 2.1% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
swift Debian:12
- Affected ranges
- ECOSYSTEM: < 1.13.1-1
Update to 1.13.1-1
swift Debian:13
- Affected ranges
- ECOSYSTEM: < 1.13.1-1
Update to 1.13.1-1
swift Debian:14
- Affected ranges
- ECOSYSTEM: < 1.13.1-1
Update to 1.13.1-1
swift PyPI
- Affected ranges
- ECOSYSTEM: ≥ 1.11.0, < 2.0.0
Update to 2.0.0
swift Ubuntu:14.04:LTS
- Versions
- 1.10.0~rc1-0ubuntu1
- 1.10.0-0ubuntu1
- 1.11.0-0ubuntu2
- 1.12.0-0ubuntu1
- 1.13.0-0ubuntu1
- 1.13.1~rc1-0ubuntu2
- 1.13.1~rc2-0ubuntu1
- 1.13.1-0ubuntu1
- Affected ranges
- ECOSYSTEM: < 1.13.1-0ubuntu1.1
Update to 1.13.1-0ubuntu1.1
Original sources
- http://www.ubuntu.com/usn/USN-2256-1
- http://secunia.com/advisories/59532
- https://review.openstack.org/#/c/101031/
- http://www.openwall.com/lists/oss-security/2014/06/19/10
- http://www.securityfocus.com/bid/68116
- http://lists.openstack.org/pipermail/openstack-announce/2014-June/000243.html
- https://review.openstack.org/#/c/101032/
- https://nvd.nist.gov/vuln/detail/CVE-2014-3497