p PatchFirst

PatchFirst · Latest vulnerabilities

swift vulnerabilities

Vulnerabilities published for swift in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 14

  1. CVE-2026-50221

    Medium · CVSS 5.3EPSS 0.22%Fix available

    CVE-2026-50221

    In OpenStack Swift before 2.37.2, proxy-server does not strip internal update headers (X-Container-Host, X-Container-Device, X-Delete-At-Host, X-Delete-At-Device) from client requests before forwarding them to object-servers. An authenticated user with write access can inject these headers to redirect container update requests to an attacker-controlled server, enabling server-side request forgery. The SSRF requests expose internal cluster metadata including storage policy indexes, partition mappings, device names, and when at rest encryption is enabled, cipher text and initialization vectors for the container-level encryption key. The attacke

    • Update to 2.37.2
    Published Updated
  2. CVE-2026-49017

    High · CVSS 7.1EPSS 0.36%No fix published

    CVE-2026-49017

    In OpenStack Swift before 2.36.2 and 2.37.2, s3api middleware enters an infinite loop when processing a truncated aws-chunked PUT request body. The StreamingInput class repeatedly appends an empty buffer and re-reads, causing the proxy-server worker handling the request to become permanently unresponsive with increasing CPU and memory consumption. An authenticated attacker can systematically exhaust all proxy-server workers, resulting in denial of service. The defect was introduced in Swift 2.36.0.

    Published Updated
  3. CVE-2022-47950

    Medium · CVSS 6.5EPSS 1.01%Fix available

    CVE-2022-47950

    An issue was discovered in OpenStack Swift before 2.28.1, 2.29.x before 2.29.2, and 2.30.0. By supplying crafted XML files, an authenticated user may coerce the S3 API into returning arbitrary file contents from the host server, resulting in unauthorized read access to potentially sensitive data. This impacts both s3api deployments (Rocky or later), and swift3 deployments (Queens and earlier, no longer actively developed).

    • Update to 2.28.1
    • Update to 2.29.2
    • Update to 2.30.1
    Published Updated
  4. CVE-2017-8761

    Medium · CVSS 4.3EPSS 0.8%Fix available

    CVE-2017-8761

    In OpenStack Swift through 2.10.1, 2.11.0 through 2.13.0, and 2.14.0, the proxy-server logs full tempurl paths, potentially leaking reusable tempurl signatures to anyone with read access to these logs. All Swift deployments using the tempurl middleware are affected.

    • Update to 2.15.2
    Published Updated
  5. CVE-2016-0738

    High · CVSS 7.5EPSS 3.85%Fix available

    CVE-2016-0738

    OpenStack Object Storage (Swift) before 2.3.1 (Kilo), 2.4.x, and 2.5.x before 2.5.1 (Liberty) do not properly close server connections, which allows remote attackers to cause a denial of service (proxy-server resource consumption) via a series of interrupted requests to a Large Object URL.

    • Update to 2.3.1
    • Update to 2.5.1
    Published Updated
  6. CVE-2016-0737

    High · CVSS 7.5EPSS 3.82%Fix available

    CVE-2016-0737

    OpenStack Object Storage (Swift) before 2.4.0 does not properly close client connections, which allows remote attackers to cause a denial of service (proxy-server resource consumption) via a series of interrupted requests to a Large Object URL.

    • Update to 2.4.0
    Published Updated
  7. CVE-2013-4155

    Not ratedEPSS 1.68%Fix available

    CVE-2013-4155

    OpenStack Swift before 1.9.1 in Folsom, Grizzly, and Havana allows authenticated users to cause a denial of service ("superfluous" tombstone consumption and Swift cluster slowdown) via a DELETE request with a timestamp that is older than expected.

    • Update to 1.9.1
    Published Updated
  8. CVE-2012-4406

    Critical · CVSS 9.8EPSS 6.57%Fix available

    CVE-2012-4406

    OpenStack Object Storage (swift) before 1.7.0 uses the loads function in the pickle Python module unsafely when storing and loading metadata in memcached, which allows remote attackers to execute arbitrary code via a crafted pickle object.

    • Update to 1.7.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →