p PatchFirst

CVE-2014-3505

CVE-2014-3505

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Double free vulnerability in d1_both.c in the DTLS implementation in OpenSSL 0.9.8 before 0.9.8zb, 1.0.0 before 1.0.0n, and 1.0.1 before 1.0.1i allows remote attackers to cause a denial of service (application crash) via crafted DTLS packets that trigger an error condition.

EPSS 46.1% · Fix available

Published
Updated

Stack: system · network

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • openssl Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.0.1i-1

    Update to 1.0.1i-1

  • openssl Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.0.1i-1

    Update to 1.0.1i-1

  • openssl Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.0.1i-1

    Update to 1.0.1i-1

  • openssl Ubuntu:14.04:LTS

    Versions
    • 1.0.1e-3ubuntu1
    • 1.0.1e-4ubuntu1
    • 1.0.1e-4ubuntu2
    • 1.0.1e-4ubuntu3
    • 1.0.1e-4ubuntu4
    • 1.0.1f-1ubuntu1
    • 1.0.1f-1ubuntu2
    • 1.0.1f-1ubuntu2.1
    • 1.0.1f-1ubuntu2.2
    • 1.0.1f-1ubuntu2.3
    • 1.0.1f-1ubuntu2.4
    Affected ranges
    • ECOSYSTEM: < 1.0.1f-1ubuntu2.5

    Update to 1.0.1f-1ubuntu2.5

Original sources

Check your server →