p PatchFirst

CVE-2014-3512

CVE-2014-3512

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Multiple buffer overflows in crypto/srp/srp_lib.c in the SRP implementation in OpenSSL 1.0.1 before 1.0.1i allow remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via an invalid SRP (1) g, (2) A, or (3) B parameter.

EPSS 74.1% · Fix available

Published
Updated

Stack: system · network

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • openssl Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.0.1i-1

    Update to 1.0.1i-1

  • openssl Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.0.1i-1

    Update to 1.0.1i-1

  • openssl Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.0.1i-1

    Update to 1.0.1i-1

  • openssl Ubuntu:14.04:LTS

    Versions
    • 1.0.1e-3ubuntu1
    • 1.0.1e-4ubuntu1
    • 1.0.1e-4ubuntu2
    • 1.0.1e-4ubuntu3
    • 1.0.1e-4ubuntu4
    • 1.0.1f-1ubuntu1
    • 1.0.1f-1ubuntu2
    • 1.0.1f-1ubuntu2.1
    • 1.0.1f-1ubuntu2.2
    • 1.0.1f-1ubuntu2.3
    • 1.0.1f-1ubuntu2.4
    Affected ranges
    • ECOSYSTEM: < 1.0.1f-1ubuntu2.5

    Update to 1.0.1f-1ubuntu2.5

Original sources

Check your server →