p PatchFirst

CVE-2014-3538

CVE-2014-3538

This page contains facts from public vulnerability sources. Check the original advisory before updating.

file before 5.19 does not properly restrict the amount of data read during a regex search, which allows remote attackers to cause a denial of service (CPU consumption) via a crafted file that triggers backtracking during processing of an awk rule. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7345.

EPSS 11.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • file Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:5.19-1

    Update to 1:5.19-1

  • file Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:5.19-1

    Update to 1:5.19-1

  • file Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:5.19-1

    Update to 1:5.19-1

  • file Ubuntu:14.04:LTS

    Versions
    • 5.11-2ubuntu4
    • 1:5.14-2ubuntu1
    • 1:5.14-2ubuntu2
    • 1:5.14-2ubuntu3
    Affected ranges
    • ECOSYSTEM: < 1:5.14-2ubuntu3.1

    Update to 1:5.14-2ubuntu3.1

Original sources

Check your server →