p PatchFirst

PatchFirst · Latest vulnerabilities

file vulnerabilities

Vulnerabilities published for file in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 17

  1. CVE-2015-8865

    High · CVSS 7.3EPSS 5.48%Fix available

    CVE-2015-8865

    The file_check_mem function in funcs.c in file before 5.23, as used in the Fileinfo component in PHP before 5.5.34, 5.6.x before 5.6.20, and 7.x before 7.0.5, mishandles continuation-level jumps, which allows context-dependent attackers to cause a denial of service (buffer overflow and application crash) or possibly execute arbitrary code via a crafted magic file.

    • Update to 1:5.14-2ubuntu3.4
    Published Updated
  2. CVE-2014-9653

    Not ratedEPSS 4.65%Fix available

    CVE-2014-9653

    readelf.c in file before 5.22, as used in the Fileinfo component in PHP before 5.4.37, 5.5.x before 5.5.21, and 5.6.x before 5.6.5, does not consider that pread calls sometimes read only a subset of the available data, which allows remote attackers to cause a denial of service (uninitialized memory access) or possibly have unspecified other impact via a crafted ELF file.

    • Update to 1:5.14-2ubuntu3.4
    Published Updated
  3. CVE-2014-9652

    Not ratedEPSS 5.24%Fix available

    CVE-2014-9652

    The mconvert function in softmagic.c in file before 5.21, as used in the Fileinfo component in PHP before 5.4.37, 5.5.x before 5.5.21, and 5.6.x before 5.6.5, does not properly handle a certain string-length field during a copy of a truncated version of a Pascal string, which might allow remote attackers to cause a denial of service (out-of-bounds memory access and application crash) via a crafted file.

    • Update to 1:5.14-2ubuntu3.3
    Published Updated
  4. CVE-2014-3710

    Not ratedEPSS 14.01%Fix available

    CVE-2014-3710

    The donote function in readelf.c in file through 5.20, as used in the Fileinfo component in PHP 5.4.34, does not ensure that sufficient note headers are present, which allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted ELF file.

    • Update to 1:5.14-2ubuntu3.3
    Published Updated
  5. CVE-2014-3587

    Not ratedEPSS 20.24%Fix available

    CVE-2014-3587

    Integer overflow in the cdf_read_property_info function in cdf.c in file through 5.19, as used in the Fileinfo component in PHP before 5.4.32 and 5.5.x before 5.5.16, allows remote attackers to cause a denial of service (application crash) via a crafted CDF file. NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-1571.

    • Update to 1:5.14-2ubuntu3.2
    Published Updated
  6. CVE-2014-3487

    Not ratedEPSS 14.93%Fix available

    CVE-2014-3487

    The cdf_read_property_info function in file before 5.19, as used in the Fileinfo component in PHP before 5.4.30 and 5.5.x before 5.5.14, does not properly validate a stream offset, which allows remote attackers to cause a denial of service (application crash) via a crafted CDF file.

    • Update to 1:5.14-2ubuntu3.1
    Published Updated
  7. CVE-2014-3480

    Medium · CVSS 6.5EPSS 11.48%Fix available

    CVE-2014-3480

    The cdf_count_chain function in cdf.c in file before 5.19, as used in the Fileinfo component in PHP before 5.4.30 and 5.5.x before 5.5.14, does not properly validate sector-count data, which allows remote attackers to cause a denial of service (application crash) via a crafted CDF file.

    • Update to 1:5.14-2ubuntu3.1
    Published Updated
  8. CVE-2014-3479

    Not ratedEPSS 14.93%Fix available

    CVE-2014-3479

    The cdf_check_stream_offset function in cdf.c in file before 5.19, as used in the Fileinfo component in PHP before 5.4.30 and 5.5.x before 5.5.14, relies on incorrect sector-size data, which allows remote attackers to cause a denial of service (application crash) via a crafted stream offset in a CDF file.

    • Update to 1:5.14-2ubuntu3.1
    Published Updated
  9. CVE-2014-3478

    Medium · CVSS 6.5EPSS 15.18%Fix available

    CVE-2014-3478

    Buffer overflow in the mconvert function in softmagic.c in file before 5.19, as used in the Fileinfo component in PHP before 5.4.30 and 5.5.x before 5.5.14, allows remote attackers to cause a denial of service (application crash) via a crafted Pascal string in a FILE_PSTRING conversion.

    • Update to 1:5.14-2ubuntu3.1
    Published Updated
  10. CVE-2014-0207

    Medium · CVSS 6.5EPSS 16.93%Fix available

    CVE-2014-0207

    The cdf_read_short_sector function in cdf.c in file before 5.19, as used in the Fileinfo component in PHP before 5.4.30 and 5.5.x before 5.5.14, allows remote attackers to cause a denial of service (assertion failure and application exit) via a crafted CDF file.

    • Update to 1:5.14-2ubuntu3.1
    Published Updated
  11. CVE-2014-3538

    Not ratedEPSS 11.81%Fix available

    CVE-2014-3538

    file before 5.19 does not properly restrict the amount of data read during a regex search, which allows remote attackers to cause a denial of service (CPU consumption) via a crafted file that triggers backtracking during processing of an awk rule. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7345.

    • Update to 1:5.14-2ubuntu3.1
    Published Updated
  12. CVE-2013-7345

    Not ratedEPSS 3.04%Fix available

    CVE-2013-7345

    The BEGIN regular expression in the awk script detector in magic/Magdir/commands in file before 5.15 uses multiple wildcards with unlimited repetitions, which allows context-dependent attackers to cause a denial of service (CPU consumption) via a crafted ASCII file that triggers a large amount of backtracking, as demonstrated via a file with many newline characters.

    • Update to 1:5.14-2ubuntu3.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →