CVE-2014-3564
CVE-2014-3564
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Multiple heap-based buffer overflows in the status_handler function in (1) engine-gpgsm.c and (2) engine-uiserver.c in GPGME before 1.5.1 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via vectors related to "different line lengths in a specific order."
EPSS 4.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
gpgme1.0 Debian:12
- Affected ranges
- ECOSYSTEM: < 1.5.1-1
Update to 1.5.1-1
gpgme1.0 Debian:13
- Affected ranges
- ECOSYSTEM: < 1.5.1-1
Update to 1.5.1-1
gpgme1.0 Debian:14
- Affected ranges
- ECOSYSTEM: < 1.5.1-1
Update to 1.5.1-1
gpgme1.0 Ubuntu:14.04:LTS
- Versions
- 1.4.2-0.1ubuntu3
- 1.4.3-0.1ubuntu2
- 1.4.3-0.1ubuntu3
- 1.4.3-0.1ubuntu5
- Affected ranges
- ECOSYSTEM: < 1.4.3-0.1ubuntu5.1
Update to 1.4.3-0.1ubuntu5.1
Original sources
- http://www.osvdb.org/109699
- http://www.securityfocus.com/bid/68990
- http://www.debian.org/security/2014/dsa-3005
- http://git.gnupg.org/cgi-bin/gitweb.cgi?p=gpgme.git%3Ba=commit%3Bh=2cbd76f7911fc215845e89b50d6af5ff4a83dd77
- https://bugzilla.redhat.com/show_bug.cgi?id=1113267
- http://seclists.org/oss-sec/2014/q3/266
- http://www.oracle.com/technetwork/topics/security/bulletinoct2015-2511968.html
- https://nvd.nist.gov/vuln/detail/CVE-2014-3564