p PatchFirst

CVE-2014-3568

CVE-2014-3568

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

OpenSSL before 0.9.8zc, 1.0.0 before 1.0.0o, and 1.0.1 before 1.0.1j does not properly enforce the no-ssl3 build option, which allows remote attackers to bypass intended access restrictions via an SSL 3.0 handshake, related to s23_clnt.c and s23_srvr.c.

EPSS 14.0% · Fix available

Published
Updated

Stack: system · network

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • openssl Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.0.1j-1

    Update to 1.0.1j-1

  • openssl Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.0.1j-1

    Update to 1.0.1j-1

  • openssl Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.0.1j-1

    Update to 1.0.1j-1

  • openssl Ubuntu:14.04:LTS

    Versions
    • 1.0.1e-3ubuntu1
    • 1.0.1e-4ubuntu1
    • 1.0.1e-4ubuntu2
    • 1.0.1e-4ubuntu3
    • 1.0.1e-4ubuntu4
    • 1.0.1f-1ubuntu1
    • 1.0.1f-1ubuntu2
    • 1.0.1f-1ubuntu2.1
    • 1.0.1f-1ubuntu2.2
    • 1.0.1f-1ubuntu2.3
    • 1.0.1f-1ubuntu2.4
    • 1.0.1f-1ubuntu2.5
    Affected ranges
    • ECOSYSTEM: < 1.0.1f-1ubuntu2.7

    Update to 1.0.1f-1ubuntu2.7

Original sources

Check your server →