p PatchFirst

CVE-2014-3686

CVE-2014-3686

This page contains facts from public vulnerability sources. Check the original advisory before updating.

wpa_supplicant and hostapd 0.7.2 through 2.2, when running with certain configurations and using wpa_cli or hostapd_cli with action scripts, allows remote attackers to execute arbitrary commands via a crafted frame.

EPSS 4.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wpa Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.3-1

    Update to 2.3-1

  • wpa Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.3-1

    Update to 2.3-1

  • wpa Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.3-1

    Update to 2.3-1

  • wpa Ubuntu:14.04:LTS

    Versions
    • 1.0-3ubuntu2
    • 1.0-3ubuntu3
    • 1.0-3ubuntu4
    • 2.1-0ubuntu1
    Affected ranges
    • ECOSYSTEM: < 2.1-0ubuntu1.1

    Update to 2.1-0ubuntu1.1

Original sources

Check your server →