p PatchFirst

PatchFirst · Latest vulnerabilities

wpa vulnerabilities

Vulnerabilities published for wpa in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 29

  1. CVE-2024-5290

    High · CVSS 8.8EPSS 0.65%Fix available

    CVE-2024-5290

    An issue was discovered in Ubuntu wpa_supplicant that resulted in loading of arbitrary shared objects, which allows a local unprivileged attacker to escalate privileges to the user that wpa_supplicant runs as (usually root). Membership in the netdev group or access to the dbus interface of wpa_supplicant allow an unprivileged user to specify an arbitrary path to a module to be loaded by the wpa_supplicant process; other escalation paths might exist.

    • Update to 2.1-0ubuntu1.7+esm5
    Published Updated
  2. CVE-2019-9499

    High · CVSS 8.1EPSS 2.21%Fix available

    The implementations of EAP-PWD in wpa_supplicant EAP Peer do not validate the scalar and element values in EAP-pwd-Commit

    The implementations of EAP-PWD in wpa_supplicant EAP Peer, when built against a crypto library missing explicit validation on imported elements, do not validate the scalar and element values in EAP-pwd-Commit. An attacker may complete authentication, session key and control of the data connection with a client. Both hostapd with SAE support and wpa_supplicant with SAE support prior to and including version 2.4 are affected. Both hostapd with EAP-pwd support and wpa_supplicant with EAP-pwd support prior to and including version 2.7 are affected.

    • Update to 2.1-0ubuntu1.7
    Published Updated
  3. CVE-2019-9498

    High · CVSS 8.1EPSS 2.21%Fix available

    The implementations of EAP-PWD in hostapd EAP Server do not validate the scalar and element values in EAP-pwd-Commit

    The implementations of EAP-PWD in hostapd EAP Server, when built against a crypto library missing explicit validation on imported elements, do not validate the scalar and element values in EAP-pwd-Commit. An attacker may be able to use invalid scalar/element values to complete authentication, gaining session key and network access without needing or learning the password. Both hostapd with SAE support and wpa_supplicant with SAE support prior to and including version 2.4 are affected. Both hostapd with EAP-pwd support and wpa_supplicant with EAP-pwd support prior to and including version 2.7 are affected.

    • Update to 2.1-0ubuntu1.7
    Published Updated
  4. CVE-2019-9497

    High · CVSS 8.1EPSS 4.99%Fix available

    The implementations of EAP-PWD in hostapd EAP Server and wpa_supplicant EAP Peer do not validate the scalar and element values in EAP-pwd-Commit

    The implementations of EAP-PWD in hostapd EAP Server and wpa_supplicant EAP Peer do not validate the scalar and element values in EAP-pwd-Commit. This vulnerability may allow an attacker to complete EAP-PWD authentication without knowing the password. However, unless the crypto library does not implement additional checks for the EC point, the attacker will not be able to derive the session key or complete the key exchange. Both hostapd with SAE support and wpa_supplicant with SAE support prior to and including version 2.4 are affected. Both hostapd with EAP-pwd support and wpa_supplicant with EAP-pwd support prior to and including version 2.

    • Update to 2.1-0ubuntu1.7
    Published Updated
  5. CVE-2019-9495

    Low · CVSS 3.7EPSS 3.48%Fix available

    The implementations of EAP-PWD in hostapd and wpa_supplicant are vulnerable to side-channel attacks as a result of cache access patterns

    The implementations of EAP-PWD in hostapd and wpa_supplicant are vulnerable to side-channel attacks as a result of cache access patterns. All versions of hostapd and wpa_supplicant with EAP-PWD support are vulnerable. The ability to install and execute applications is necessary for a successful attack. Memory access patterns are visible in a shared cache. Weak passwords may be cracked. Versions of hostapd/wpa_supplicant 2.7 and newer, are not vulnerable to the timing attack described in CVE-2019-9494. Both hostapd with EAP-pwd support and wpa_supplicant with EAP-pwd support prior to and including version 2.7 are affected.

    • Update to 2.1-0ubuntu1.7
    Published Updated
  6. CVE-2018-14526

    Medium · CVSS 6.5EPSS 1.48%Fix available

    CVE-2018-14526

    An issue was discovered in rsn_supp/wpa.c in wpa_supplicant 2.0 through 2.6. Under certain conditions, the integrity of EAPOL-Key messages is not checked, leading to a decryption oracle. An attacker within range of the Access Point and client can abuse the vulnerability to recover sensitive information.

    • Update to 2.1-0ubuntu1.6
    Published Updated
  7. CVE-2015-5315

    Medium · CVSS 5.9EPSS 2.52%Fix available

    CVE-2015-5315

    The eap_pwd_process function in eap_peer/eap_pwd.c in wpa_supplicant 2.x before 2.6 does not validate that the reassembly buffer is large enough for the final fragment when EAP-pwd is enabled in a network configuration profile, which allows remote attackers to cause a denial of service (process termination) via a large final fragment in an EAP-pwd message.

    • Update to 2.1-0ubuntu1.4
    Published Updated
  8. CVE-2015-5314

    Medium · CVSS 5.9EPSS 2.27%Fix available

    CVE-2015-5314

    The eap_pwd_process function in eap_server/eap_server_pwd.c in hostapd 2.x before 2.6 does not validate that the reassembly buffer is large enough for the final fragment when used with (1) an internal EAP server or (2) a RADIUS server and EAP-pwd is enabled in a runtime configuration, which allows remote attackers to cause a denial of service (process termination) via a large final fragment in an EAP-pwd message.

    • Update to 2.1-0ubuntu1.4
    Published Updated
  9. CVE-2017-13088

    Medium · CVSS 5.3EPSS 1.81%Fix available

    CVE-2017-13088

    Wi-Fi Protected Access (WPA and WPA2) that support 802.11v allows reinstallation of the Integrity Group Temporal Key (IGTK) when processing a Wireless Network Management (WNM) Sleep Mode Response frame, allowing an attacker within radio range to replay frames from access points to clients.

    • Update to 2.1-0ubuntu1.5
    Published Updated
  10. CVE-2017-13087

    Medium · CVSS 5.3EPSS 1.74%Fix available

    CVE-2017-13087

    Wi-Fi Protected Access (WPA and WPA2) that support 802.11v allows reinstallation of the Group Temporal Key (GTK) when processing a Wireless Network Management (WNM) Sleep Mode Response frame, allowing an attacker within radio range to replay frames from access points to clients.

    • Update to 2.1-0ubuntu1.5
    Published Updated
  11. CVE-2017-13082

    High · CVSS 8.1EPSS 4.58%Fix available

    CVE-2017-13082

    Wi-Fi Protected Access (WPA and WPA2) that supports IEEE 802.11r allows reinstallation of the Pairwise Transient Key (PTK) Temporal Key (TK) during the fast BSS transmission (FT) handshake, allowing an attacker within radio range to replay, decrypt, or spoof frames.

    • Update to 2.1-0ubuntu1.5
    Published Updated
  12. CVE-2016-4477

    High · CVSS 7.8EPSS 0.26%Fix available

    CVE-2016-4477

    wpa_supplicant 0.4.0 through 2.5 does not reject \n and \r characters in passphrase parameters, which allows local users to trigger arbitrary library loading and consequently gain privileges, or cause a denial of service (daemon outage), via a crafted (1) SET, (2) SET_CRED, or (3) SET_NETWORK command.

    • Update to 2.1-0ubuntu1.5
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →