CVE-2014-4617
CVE-2014-4617
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The do_uncompress function in g10/compress.c in GnuPG 1.x before 1.4.17 and 2.x before 2.0.24 allows context-dependent attackers to cause a denial of service (infinite loop) via malformed compressed packets, as demonstrated by an a3 01 5b ff byte sequence.
EPSS 3.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
gnupg2 Debian:12
- Affected ranges
- ECOSYSTEM: < 2.0.24-1
Update to 2.0.24-1
gnupg2 Debian:13
- Affected ranges
- ECOSYSTEM: < 2.0.24-1
Update to 2.0.24-1
gnupg2 Debian:14
- Affected ranges
- ECOSYSTEM: < 2.0.24-1
Update to 2.0.24-1
gnupg Ubuntu:14.04:LTS
- Versions
- 1.4.14-1ubuntu2
- 1.4.15-1.1ubuntu1
- 1.4.15-1.1ubuntu2
- 1.4.15-2ubuntu1
- 1.4.16-1ubuntu1
- 1.4.16-1ubuntu2
- Affected ranges
- ECOSYSTEM: < 1.4.16-1ubuntu2.1
Update to 1.4.16-1ubuntu2.1
gnupg2 Ubuntu:14.04:LTS
- Versions
- 2.0.20-1ubuntu3
- 2.0.22-1ubuntu1
- 2.0.22-3ubuntu1
- Affected ranges
- ECOSYSTEM: < 2.0.22-3ubuntu1.1
Update to 2.0.22-3ubuntu1.1
Original sources
- http://secunia.com/advisories/59351
- http://secunia.com/advisories/59578
- http://lists.gnupg.org/pipermail/gnupg-announce/2014q2/000345.html
- http://www.debian.org/security/2014/dsa-2967
- http://lists.opensuse.org/opensuse-updates/2014-07/msg00010.html
- http://git.gnupg.org/cgi-bin/gitweb.cgi?p=gnupg.git%3Ba=commit%3Bh=014b2103fcb12f261135e3954f26e9e07b39e342
- http://www.ubuntu.com/usn/USN-2258-1
- http://www.oracle.com/technetwork/topics/security/bulletinapr2015-2511959.html
- http://www.debian.org/security/2014/dsa-2968
- http://git.gnupg.org/cgi-bin/gitweb.cgi?p=gnupg.git%3Ba=commit%3Bh=11fdfcf82bd8d2b5bc38292a29876e10770f4b0a
- http://secunia.com/advisories/59534
- http://secunia.com/advisories/59213
- http://lists.gnupg.org/pipermail/gnupg-announce/2014q2/000344.html
- https://nvd.nist.gov/vuln/detail/CVE-2014-4617