p PatchFirst

PatchFirst · Latest vulnerabilities

gnupg vulnerabilities

Vulnerabilities published for gnupg in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 8

  1. CVE-2015-0837

    Medium · CVSS 5.9EPSS 1.95%Fix available

    CVE-2015-0837

    The mpi_powm function in Libgcrypt before 1.6.3 and GnuPG before 1.4.19 allows attackers to obtain sensitive information by leveraging timing differences when accessing a pre-computed table during modular exponentiation, related to a "Last-Level Cache Side-Channel Attack."

    • Update to 1.4.16-1ubuntu2.3
    Published Updated
  2. CVE-2014-3591

    Medium · CVSS 4.2EPSS 0.6%Fix available

    CVE-2014-3591

    Libgcrypt before 1.6.3 and GnuPG before 1.4.19 does not implement ciphertext blinding for Elgamal decryption, which allows physically proximate attackers to obtain the server's private key by determining factors using crafted ciphertext and the fluctuations in the electromagnetic field during multiplication.

    • Update to 1.4.16-1ubuntu2.3
    Published Updated
  3. CVE-2015-1607

    Medium · CVSS 5.5EPSS 2.47%Fix available

    CVE-2015-1607

    kbx/keybox-search.c in GnuPG before 1.4.19, 2.0.x before 2.0.27, and 2.1.x before 2.1.2 does not properly handle bitwise left-shifts, which allows remote attackers to cause a denial of service (invalid read operation) via a crafted keyring file, related to sign extensions and "memcpy with overlapping ranges."

    • Update to 1.4.16-1ubuntu2.3
    Published Updated
  4. CVE-2017-7526

    Medium · CVSS 6.1EPSS 3.84%Fix available

    CVE-2017-7526

    libgcrypt before version 1.7.8 is vulnerable to a cache side-channel attack resulting into a complete break of RSA-1024 while using the left-to-right method for computing the sliding-window expansion. The same attack is believed to work on RSA-2048 with moderately more computation. This side-channel requires that attacker can run arbitrary software on the hardware where the private RSA key is used.

    • Update to 1.4.16-1ubuntu2.6
    Published Updated
  5. CVE-2018-12020

    High · CVSS 7.5EPSS 8.25%Fix available

    CVE-2018-12020

    mainproc.c in GnuPG before 2.2.8 mishandles the original filename during decryption and verification actions, which allows remote attackers to spoof the output that GnuPG sends on file descriptor 2 to other programs that use the "--status-fd 2" option. For example, the OpenPGP data might represent an original filename that contains line feed characters in conjunction with GOODSIG or VALIDSIG status codes.

    • Update to 1.4.16-1ubuntu2.5
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →