p PatchFirst

CVE-2014-4986

CVE-2014-4986

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Multiple cross-site scripting (XSS) vulnerabilities in js/functions.js in phpMyAdmin 4.0.x before 4.0.10.1, 4.1.x before 4.1.14.2, and 4.2.x before 4.2.6 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) table name or (2) column name that is improperly handled during construction of an AJAX confirmation message.

EPSS 1.6% · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • phpmyadmin Debian:12

    Affected ranges
    • ECOSYSTEM: < 4:4.2.6-1

    Update to 4:4.2.6-1

  • phpmyadmin Debian:13

    Affected ranges
    • ECOSYSTEM: < 4:4.2.6-1

    Update to 4:4.2.6-1

  • phpmyadmin Debian:14

    Affected ranges
    • ECOSYSTEM: < 4:4.2.6-1

    Update to 4:4.2.6-1

  • phpmyadmin/phpmyadmin Packagist

    Versions
    • 4.0.0
    • 4.0.1
    • 4.0.10
    • 4.0.2
    • 4.0.3
    • 4.0.4
    • 4.0.4.1
    • 4.0.4.2
    • 4.0.5
    • 4.0.6
    • 4.0.7
    • 4.0.8
    • 4.0.9
    Affected ranges
    • ECOSYSTEM: ≥ 4.0.0, < 4.0.10.1

    Update to 4.0.10.1

  • phpmyadmin/phpmyadmin Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 4.1.0, < 4.1.14.2

    Update to 4.1.14.2

  • phpmyadmin/phpmyadmin Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 4.2.0, < 4.2.6

    Update to 4.2.6

  • phpmyadmin Ubuntu:Pro:14.04:LTS

    Versions
    • 4:4.0.6-1
    • 4:4.0.8-1
    • 4:4.0.9-1
    • 4:4.0.10-1
    • 4:4.0.10-1ubuntu0.1
    • 4:4.0.10-1ubuntu0.1+esm1
    • 4:4.0.10-1ubuntu0.1+esm2
    • 4:4.0.10-1ubuntu0.1+esm3
    • 4:4.0.10-1ubuntu0.1+esm4
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →