p PatchFirst

PatchFirst · Latest vulnerabilities

phpmyadmin vulnerabilities

Vulnerabilities published for phpmyadmin in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 110

  1. CVE-2021-21252

    Medium · CVSS 5.3EPSS 3.57%No fix published

    Regular expression denial of service in jquery-validation

    The jQuery Validation Plugin provides drop-in validation for your existing forms. It is published as an npm package "jquery-validation". jquery-validation before version 1.19.3 contains one or more regular expressions that are vulnerable to ReDoS (Regular Expression Denial of Service). This is fixed in 1.19.3.

    Published Updated
  2. CVE-2020-10802

    High · CVSS 8EPSS 1.82%No fix published

    CVE-2020-10802

    In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability has been discovered where certain parameters are not properly escaped when generating certain queries for search actions in libraries/classes/Controllers/Table/TableSearchController.php. An attacker can generate a crafted database or table name. The attack can be performed if a user attempts certain search operations on the malicious database or table.

    Published Updated
  3. CVE-2020-10803

    Medium · CVSS 5.4EPSS 1.37%No fix published

    CVE-2020-10803

    In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability was discovered where malicious code could be used to trigger an XSS attack through retrieving and displaying results (in tbl_get_field.php and libraries/classes/Display/Results.php). The attacker must be able to insert crafted data into certain database tables, which when retrieved (for instance, through the Browse tab) can trigger the XSS attack.

    Published Updated
  4. CVE-2020-10804

    High · CVSS 8EPSS 2.35%No fix published

    CVE-2020-10804

    In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability was found in retrieval of the current username (in libraries/classes/Server/Privileges.php and libraries/classes/UserPassword.php). A malicious user with access to the server could create a crafted username, and then trick the victim into performing specific actions with that user account (such as editing its privileges).

    Published Updated
  5. CVE-2019-12616

    Medium · CVSS 6.5EPSS 20.22%Public exploitFix available

    CVE-2019-12616

    An issue was discovered in phpMyAdmin before 4.9.0. A vulnerability was found that allows an attacker to trigger a CSRF attack against a phpMyAdmin user. The attacker can trick the user, for instance through a broken <img> tag pointing at the victim's phpMyAdmin database, and the attacker can potentially deliver a payload (such as a specific INSERT or DELETE statement) to the victim.

    • Update to 4:4.0.10-1ubuntu0.1+esm1
    Published Updated
  6. CVE-2019-6799

    Medium · CVSS 5.9EPSS 14.83%Public exploitNo fix published

    CVE-2019-6799

    An issue was discovered in phpMyAdmin before 4.8.5. When the AllowArbitraryServer configuration setting is set to true, with the use of a rogue MySQL server, an attacker can read any file on the server that the web server's user can access. This is related to the mysql.allow_local_infile PHP configuration, and the inadvertent ignoring of "options(MYSQLI_OPT_LOCAL_INFILE" calls.

    Published Updated
  7. CVE-2018-19969

    High · CVSS 8.8EPSS 1.06%No fix published

    CVE-2018-19969

    phpMyAdmin 4.7.x and 4.8.x versions prior to 4.8.4 are affected by a series of CSRF flaws. By deceiving a user into clicking on a crafted URL, it is possible to perform harmful SQL operations such as renaming databases, creating new tables/routines, deleting designer pages, adding/deleting users, updating user passwords, killing SQL processes, etc.

    Published Updated
  8. CVE-2018-19968

    Medium · CVSS 6.5EPSS 2.89%Fix available

    CVE-2018-19968

    An attacker can exploit phpMyAdmin before 4.8.4 to leak the contents of a local file because of an error in the transformation feature. The attacker must have access to the phpMyAdmin Configuration Storage tables, although these can easily be created in any database to which the attacker has access. An attacker must have valid credentials to log in to phpMyAdmin; this vulnerability does not allow an attacker to circumvent the login system.

    • Update to 4:4.0.10-1ubuntu0.1+esm4
    Published Updated
  9. CVE-2017-18264

    Critical · CVSS 9.8EPSS 2.82%Fix available

    CVE-2017-18264

    An issue was discovered in libraries/common.inc.php in phpMyAdmin 4.0 before 4.0.10.20, 4.4.x, 4.6.x, and 4.7.0 prereleases. The restrictions caused by $cfg['Servers'][$i]['AllowNoPassword'] = false are bypassed under certain PHP versions (e.g., version 5). This can allow the login of users who have no password set even if the administrator has set $cfg['Servers'][$i]['AllowNoPassword'] to false (which is also the default). This occurs because some implementations of the PHP substr function return false when given '' as the first argument.

    • Update to 4:4.0.10-1ubuntu0.1+esm4
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →