CVE-2014-5266
CVE-2014-5266
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The Incutio XML-RPC (IXR) Library, as used in WordPress before 3.9.2 and Drupal 6.x before 6.33 and 7.x before 7.31, does not limit the number of elements in an XML document, which allows remote attackers to cause a denial of service (CPU consumption) via a large document, a different vulnerability than CVE-2014-5265.
EPSS 25.2% · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wordpress Debian:12
- Affected ranges
- ECOSYSTEM: < 3.9.2+dfsg-1
Update to 3.9.2+dfsg-1
wordpress Debian:13
- Affected ranges
- ECOSYSTEM: < 3.9.2+dfsg-1
Update to 3.9.2+dfsg-1
wordpress Debian:14
- Affected ranges
- ECOSYSTEM: < 3.9.2+dfsg-1
Update to 3.9.2+dfsg-1
wordpress Ubuntu:14.04:LTS
- Versions
- 3.6.1+dfsg-1
- 3.7.1+dfsg-1
- 3.8.1+dfsg-1
- 3.8.1+dfsg1-2
- 3.8.2+dfsg-1
- Affected ranges
- ECOSYSTEM: < 3.8.2+dfsg-1ubuntu0.1
Update to 3.8.2+dfsg-1ubuntu0.1
drupal7 Ubuntu:Pro:14.04:LTS
- Versions
- 7.23-1
- 7.24-1
- 7.24-2
- 7.26-1
- 7.26-1ubuntu0.1
- 7.26-1ubuntu0.1+esm1
- 7.26-1ubuntu0.1+esm2
- 7.26-1ubuntu0.1+esm3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- http://www.debian.org/security/2014/dsa-3001
- https://wordpress.org/news/2014/08/wordpress-3-9-2/
- https://www.drupal.org/SA-CORE-2014-004
- http://cgit.drupalcode.org/drupal/diff/includes/xmlrpc.inc?id=1849830
- http://www.debian.org/security/2014/dsa-2999
- http://cgit.drupalcode.org/drupal/diff/modules/openid/xrds.inc?id=1849830
- https://core.trac.wordpress.org/changeset/29404
- https://nvd.nist.gov/vuln/detail/CVE-2014-5266