p PatchFirst

CVE-2014-6040

CVE-2014-6040

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GNU C Library (aka glibc) before 2.20 allows context-dependent attackers to cause a denial of service (out-of-bounds read and crash) via a multibyte character value of "0xffff" to the iconv function when converting (1) IBM933, (2) IBM935, (3) IBM937, (4) IBM939, or (5) IBM1364 encoded data to UTF-8.

EPSS 6.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • glibc Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.19-12

    Update to 2.19-12

  • glibc Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.19-12

    Update to 2.19-12

  • glibc Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.19-12

    Update to 2.19-12

  • eglibc Ubuntu:14.04:LTS

    Versions
    • 2.17-93ubuntu4
    • 2.18-0ubuntu1
    • 2.18-0ubuntu2
    • 2.18-0ubuntu4
    • 2.18-0ubuntu5
    • 2.18-0ubuntu6
    • 2.18-0ubuntu7
    • 2.19-0ubuntu2
    • 2.19-0ubuntu3
    • 2.19-0ubuntu4
    • 2.19-0ubuntu5
    • 2.19-0ubuntu6
    • 2.19-0ubuntu6.1
    • 2.19-0ubuntu6.3
    Affected ranges
    • ECOSYSTEM: < 2.19-0ubuntu6.4

    Update to 2.19-0ubuntu6.4

Original sources

Check your server →