CVE-2014-6393
CVE-2014-6393
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The Express web framework before 3.11 and 4.x before 4.5 for Node.js does not provide a charset field in HTTP Content-Type headers in 400 level responses, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via characters in a non-standard encoding.
CVSS 6.1 · Medium · EPSS 1.1% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
node-express Debian:12
- Affected ranges
- ECOSYSTEM: < 4.16.4-1
Update to 4.16.4-1
node-express Debian:13
- Affected ranges
- ECOSYSTEM: < 4.16.4-1
Update to 4.16.4-1
node-express Debian:14
- Affected ranges
- ECOSYSTEM: < 4.16.4-1
Update to 4.16.4-1
express npm
- Affected ranges
- SEMVER: < 3.11.0
Update to 3.11.0
express npm
- Affected ranges
- SEMVER: ≥ 4.0.0, < 4.5.0
Update to 4.5.0
node-express Ubuntu:Pro:16.04:LTS
- Versions
- 4.1.1~dfsg-1
- 4.1.1~dfsg-1ubuntu0.16.04.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-express Ubuntu:Pro:18.04:LTS
- Versions
- 4.1.1~dfsg-1
- 4.1.1~dfsg-1ubuntu0.18.04.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published