p PatchFirst

PatchFirst · Latest vulnerabilities

node-express vulnerabilities

Vulnerabilities published for node-express in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. CVE-2024-10491

    Medium · CVSS 4EPSS 0.44%Fix available

    Preload arbitrary resources by injecting additional `Link` headers

    A vulnerability has been identified in the Express response.links function, allowing for arbitrary resource injection in the Link header when unsanitized data is used. The issue arises from improper sanitization in `Link` header values, which can allow a combination of characters like `,`, `;`, and `<>` to preload malicious resources. This vulnerability is especially relevant for dynamic parameters.

    • Update to 4.1.1~dfsg-1
    Published Updated
  2. CVE-2024-29041

    Medium · CVSS 6.1EPSS 0.79%Fix available

    Express.js Open Redirect in malformed URLs

    Express.js minimalist web framework for node. Versions of Express.js prior to 4.19.0 and all pre-release alpha and beta versions of 5.0 are affected by an open redirect vulnerability using malformed URLs. When a user of Express performs a redirect using a user-provided URL Express performs an encode [using `encodeurl`](https://github.com/pillarjs/encodeurl) on the contents before passing it to the `location` header. This can cause malformed URLs to be evaluated in unexpected ways by common redirect allow list implementations in Express applications, leading to an Open Redirect via bypass of a properly implemented allow list. The main method i

    • Update to 4.19.2+~cs8.36.21-1
    Published Updated
  3. CVE-2014-6393

    Medium · CVSS 6.1EPSS 1.14%Fix available

    CVE-2014-6393

    The Express web framework before 3.11 and 4.x before 4.5 for Node.js does not provide a charset field in HTTP Content-Type headers in 400 level responses, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via characters in a non-standard encoding.

    • Update to 4.16.4-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →