p PatchFirst

CVE-2014-8117

CVE-2014-8117

This page contains facts from public vulnerability sources. Check the original advisory before updating.

softmagic.c in file before 5.21 does not properly limit recursion, which allows remote attackers to cause a denial of service (CPU consumption or crash) via unspecified vectors.

EPSS 5.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • file Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:5.21+15-1

    Update to 1:5.21+15-1

  • file Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:5.21+15-1

    Update to 1:5.21+15-1

  • file Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:5.21+15-1

    Update to 1:5.21+15-1

  • file Ubuntu:14.04:LTS

    Versions
    • 5.11-2ubuntu4
    • 1:5.14-2ubuntu1
    • 1:5.14-2ubuntu2
    • 1:5.14-2ubuntu3
    • 1:5.14-2ubuntu3.1
    • 1:5.14-2ubuntu3.2
    Affected ranges
    • ECOSYSTEM: < 1:5.14-2ubuntu3.3

    Update to 1:5.14-2ubuntu3.3

  • php5 Ubuntu:14.04:LTS

    Versions
    • 5.5.3+dfsg-1ubuntu2
    • 5.5.3+dfsg-1ubuntu3
    • 5.5.6+dfsg-1ubuntu1
    • 5.5.6+dfsg-1ubuntu2
    • 5.5.8+dfsg-2ubuntu1
    • 5.5.9+dfsg-1ubuntu1
    • 5.5.9+dfsg-1ubuntu2
    • 5.5.9+dfsg-1ubuntu3
    • 5.5.9+dfsg-1ubuntu4
    • 5.5.9+dfsg-1ubuntu4.1
    • 5.5.9+dfsg-1ubuntu4.2
    • 5.5.9+dfsg-1ubuntu4.3
    • 5.5.9+dfsg-1ubuntu4.4
    • 5.5.9+dfsg-1ubuntu4.5
    • 5.5.9+dfsg-1ubuntu4.6
    Affected ranges
    • ECOSYSTEM: < 5.5.9+dfsg-1ubuntu4.7

    Update to 5.5.9+dfsg-1ubuntu4.7

Original sources

Check your server →