CVE-2014-8639
CVE-2014-8639
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This page shows selected source facts. See the linked advisories for the complete description and affected versions.
Mozilla Firefox before 35.0, Firefox ESR 31.x before 31.4, Thunderbird before 31.4, and SeaMonkey before 2.32 do not properly interpret Set-Cookie headers within responses that have a 407 (aka Proxy Authentication Required) status code, which allows remote HTTP proxy servers to conduct session fixation attacks by providing a cookie name that corresponds to the session cookie of the origin server.
EPSS 1.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
firefox Ubuntu:14.04:LTS
- Versions
- 24.0+build1-0ubuntu1
- 25.0+build3-0ubuntu0.13.10.1
- 28.0~b2+build1-0ubuntu2
- 28.0+build1-0ubuntu1
- 28.0+build2-0ubuntu1
- 28.0+build2-0ubuntu2
- 29.0+build1-0ubuntu0.14.04.2
- 30.0+build1-0ubuntu0.14.04.3
- 31.0+build1-0ubuntu0.14.04.1
- 32.0+build1-0ubuntu0.14.04.1
- 32.0.3+build1-0ubuntu0.14.04.1
- 33.0+build2-0ubuntu0.14.04.1
- 34.0+build2-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 35.0+build3-0ubuntu0.14.04.2
Update to 35.0+build3-0ubuntu0.14.04.2
thunderbird Ubuntu:14.04:LTS
- Versions
- 1:24.0+build1-0ubuntu1
- 1:24.0+build1-0ubuntu2
- 1:24.1.1+build1-0ubuntu0.13.10.1
- 1:24.1.1+build1-0ubuntu1
- 1:24.2.0+build1-0ubuntu1
- 1:24.4.0+build1-0ubuntu1
- 1:24.5.0+build1-0ubuntu0.14.04.1
- 1:24.6.0+build1-0ubuntu0.14.04.1
- 1:31.0+build1-0ubuntu0.14.04.1
- 1:31.1.1+build1-0ubuntu0.14.04.1
- 1:31.1.2+build1-0ubuntu0.14.04.1
- 1:31.2.0+build2-0ubuntu0.14.04.1
- 1:31.3.0+build1-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 1:31.4.0+build1-0ubuntu0.14.04.1
Update to 1:31.4.0+build1-0ubuntu0.14.04.1
Original sources
- http://rhn.redhat.com/errata/RHSA-2015-0046.html
- http://secunia.com/advisories/62242
- http://www.securitytracker.com/id/1031533
- http://www.ubuntu.com/usn/USN-2460-1
- http://lists.opensuse.org/opensuse-security-announce/2015-02/msg00002.html
- http://secunia.com/advisories/62304
- http://linux.oracle.com/errata/ELSA-2015-0047.html
- http://secunia.com/advisories/62259
- http://secunia.com/advisories/62250
- http://lists.opensuse.org/opensuse-security-announce/2015-01/msg00033.html
- http://secunia.com/advisories/62237
- http://lists.opensuse.org/opensuse-security-announce/2015-01/msg00014.html
- http://secunia.com/advisories/62418
- http://lists.opensuse.org/opensuse-security-announce/2015-01/msg00032.html
- http://secunia.com/advisories/62316
- http://www.debian.org/security/2015/dsa-3132
- http://secunia.com/advisories/62274
- https://exchange.xforce.ibmcloud.com/vulnerabilities/99959
- https://security.gentoo.org/glsa/201504-01
- http://secunia.com/advisories/62313
- http://rhn.redhat.com/errata/RHSA-2015-0047.html
- http://secunia.com/advisories/62790
- http://secunia.com/advisories/62293
- https://nvd.nist.gov/vuln/detail/CVE-2014-8639