p PatchFirst

CVE-2014-8684

CVE-2014-8684

This page contains facts from public vulnerability sources. Check the original advisory before updating.

CodeIgniter before 3.0 and Kohana 3.2.3 and earlier and 3.3.x through 3.3.2 make it easier for remote attackers to spoof session cookies and consequently conduct PHP object injection attacks by leveraging use of standard string comparison operators to compare cryptographic hashes.

CVSS 9.8 · Critical · EPSS 72.2% · Public exploit · Fix available

Published
Updated

Stack: php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • codeigniter/framework Packagist

    Versions
    • 3.0rc
    • 3.0rc2
    • 3.0rc3
    Affected ranges
    • ECOSYSTEM: < 3.0.0

    Update to 3.0.0

  • kohana/core Packagist

    Versions
    • v3.2.3
    • v3.3.1
    • v3.3.2
    Affected ranges
    • ECOSYSTEM: < 3.3.3

    Update to 3.3.3

Original sources

Check your server →