p PatchFirst

PatchFirst · Latest vulnerabilities

codeigniter/framework vulnerabilities

Vulnerabilities published for codeigniter/framework in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. GHSA-27qr-636m-wxg2

    Critical · CVSS 10Fix available

    codeigniter/framework SQL injection in ODBC database driver

    CodeIgniter 3.1.0 addressed a critical security issue within the ODBC database driver. This update includes crucial fixes to mitigate a SQL injection vulnerability, preventing potential exploitation by attackers. It is noteworthy that these fixes render the query builder and escape() functions incompatible with the ODBC driver. However, the update introduces actual query binding as a more secure alternative.

    • Update to 3.1.0
    Published Updated
  2. GHSA-q9j3-4ghj-6h57

    Medium · CVSS 4.7Fix available

    Inadequate XSS Prevention in CodeIgniter/Framework Security Library

    The xss_clean() method in the Security Library of CodeIgniter/Framework, specifically in versions before 3.0.3, exhibited a vulnerability that allowed certain Cross-Site Scripting (XSS) vectors to bypass its intended protection mechanisms. The xss_clean() method is designed to sanitize input data by removing potentially malicious content, thus preventing XSS attacks. However, in versions prior to 3.0.3, it was discovered that the method did not adequately mitigate specific XSS vectors, leaving a potential security gap.

    • Update to 3.0.3
    Published Updated
  3. CVE-2014-8684

    Critical · CVSS 9.8EPSS 72.16%Public exploitFix available

    CVE-2014-8684

    CodeIgniter before 3.0 and Kohana 3.2.3 and earlier and 3.3.x through 3.3.2 make it easier for remote attackers to spoof session cookies and consequently conduct PHP object injection attacks by leveraging use of standard string comparison operators to compare cryptographic hashes.

    • Update to 3.0.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →